Subaru Impreza GC8 & RS Forum & Community banner

3741 - 3756 of 3756 Posts

·
Registered
05 STi WannaBE
Joined
·
6,055 Posts
Discussion Starter #3,741 (Edited)


Ran compression test on all four and everything looks strong. Number 2&4 spark plug looks like they are either not combusting all of my fuel or something else is going on. They were pretty caked up. As from my previous post about running the NGK Iridium for so many years and having shitty soot coming out the back end, I found out that N/As work better with the Platinum plugs so that's what I installed. I just cleaned the MAF and did a complete ECU relearn. I'm just waiting for the motor to cool off before I see how it drives. I'm praying it drives like a bat out of hell ;)
 

·
Registered
Turbo, LS swapped Impreza RS
Joined
·
5,166 Posts
Copper plugs off the most performance spark wise compared to iridium and platinum. They just don't last nearly as long so people started saying the iridium plugs were "better". This isn't the case, they just have a longer life span. My school's race team runs coppers in there 900hp big block sprints.

Sent from my SM-N920V using Tapatalk
 

·
Registered
05 STi WannaBE
Joined
·
6,055 Posts
Discussion Starter #3,744
So here it is folks! My car runs 100% stronger now. As soon as I step on the throttle she responds and hauls ass through the gears. I threw her in high gear while cruising and she just keeps going without a hitch. I'm so damn happy I got her running her best again. I should see better gas mileage and over all better smoother driving now.
 

·
Registered
05 STi WannaBE
Joined
·
6,055 Posts
Discussion Starter #3,746
Sucks, now I fix my car and I go to OKC to help our fellow AT&T brothers out for a month. I wont be able to take my car and its supposed to snow up there. My car will be parked at the AT&T building for the time being. I'm going to disconnect the battery while I'm gone.
 

·
Registered
white bugeye 25rs
Joined
·
33 Posts
Did you ever find out what the issue was or did you just swap the trans? My car is currently doing what you described.


Trying to figure out what's going on with my transmission without having to pull it out just yet. From viewing other videos on this matter, it seems to sound like a center differential bearing noise. You can hear multiple noises from the engine stroking to the whining noises of each gear in the transmission. The whine seems to get higher as I go higher up in the gears. When I disengage the clutch the noise stops. When I let off the gas (while still in gear and clutch still engaged) it doesn't whine. It only whines when I apply the gas. You can hear the whine start and stop as I randomly step on and off of the gas. This noise is not only heard from the inside of the car but also from the outside as I was driving next to a long concrete wall and the sounds was bouncing off of it. While slowing down and in gear there is a chattering noise that can be heard but it isn't as loud as the whining.

Now with all of this being said, there are ZERO driving problems with the car. It shifts through all of the gears like butter with no grinding in any of the gears.

*Placed microphone inside the center dash just behind the shifter section.

Related modifications:

Light Weight Flywheel + 06 WRX oem Exedy clutch + 06 WRX clutch fork
Group-N transmission mount
Group-N engine mount
Whiteline transmission cross member mounts
Solid Pitch Stop mount (Dogbone)
 

·
Registered
05 STi WannaBE
Joined
·
6,055 Posts
Discussion Starter #3,750
:(


Means more fun time when you return
Chris, I just got back today from being away for a whole month. I couldn't wait to drive my car around again. Firth thing I did was wash it. Good think is I had my good friend Jack hold on to my car for the month at his house. He would start it every now and then and drive it wherever just to keep it fresh.

PS, I'm going back up there for another 6 weeks but I'm not complaining because these paychecks are $$
 
3741 - 3756 of 3756 Posts
Top