Subaru Impreza GC8 & RS Forum & Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have a 97 OBS and Last week I noticed my Rear Defroster Switch Light was out So I took off the cover and pulled out the Switch it had a bad bulb so I ordered a new switch from the dealer. ($37.97).
After a day or two of waiting I went to autozone and got a rocker switch and put that in. I must have pluged it in the wrong set of pins on the plug because now I have no Dash lights. But the funny thing is that the radio backlight works when the car lights are off but when I turn them on the Radio back light goes oFF.? I have pulled out
every fuse and chedked them They are all good. So my question is, is it a fuse or did I blow out The dash LightBulb.??
Thanks For Your Help In Advance
 

·
Premium Member
Two Mini Coopers!
Joined
·
10,629 Posts
Most likely - a fuse. However, it sounds like you may have messed up some resistor or diode on the circuit board for the dash. If this is the case, that's beyond my scope of knowledge.

Your radio light is on a different circuit, probably and that is why it works.

If you pulled all the circuits under the dash, you might also consider checking the fuses under the hood. Beware - pulling some of those might also have serious implications - I'd STRONGLY recommend you remove the negative cable from your battery before pulling the under hood fuses.

If all else fails, consider calling a local Subar shop or your dealer.
 
1 - 2 of 2 Posts
Top