Subaru Impreza GC8 & RS Forum & Community banner
1 - 10 of 10 Posts

·
Registered
1998 impreza 2.5rs
Joined
·
630 Posts
Discussion Starter · #1 ·
My buddies oil pressure light is coming on and off randomly, so we're thinking first step is replace the sensor, as other threads have stated. They also stated that it's located under the alternator and between that and the power steering pump. Okay, I know where the alternator is, but I don't know where the power steering pump is or what it looks like. I don't have a haynes manual or anything like that (yet) so I'm hoping someone can throw some pictures my way so I have a better idea of what to look for. I'm going out to go look at the car in the meantime, but any help is appreciated. Thanks!!
 

·
Registered
02' PSM WRX
Joined
·
1,535 Posts
under the alternator there is only one sensor that is screwed into the block. has a one wire plug attached to it. a spade type connector. that is the oil press sensor.

also what model of car is it? wrx sti rs?
 

·
Registered
02' PSM WRX
Joined
·
1,535 Posts
das yellow one! oil pressure.

red one is the crank sensor.

and yeah on the 98 and 99 block, those sensors are in the same position...
 

·
Premium Member
overdeveloped beater
Joined
·
8,335 Posts
the FIRST thing you should check is the oil level......always start with the easy stuff.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
If the oil is fine and you change the sensor and still have problems, remove the oil pump assembly and tighten its internal screws. Be sure to use a new o ring on the pressure side and cleant the block and pump well before re glueing it with fujibond or equivalent.
 
1 - 10 of 10 Posts
Top