Subaru Impreza GC8 & RS Forum & Community banner

1 - 16 of 16 Posts

·
Registered
type RRRRAAAAAA
Joined
·
741 Posts
Discussion Starter #1
so today i was sitting in traffic not for that long .. and i noticed my water temp started to go up.. i know my engine over heats if i idle for like 30 min because i only have one fan in.. why because the koyo is thicker and i cant fit the fan in...

well anyway.. so i pull over and i didnt want to open the radiator cap .. but i squeeze the top radiator hose and it seems like its empty.. after a while i got home..cool down for a little and notice my coolant was really low!! so i remember i topped it off 1 month ago.... so during this 1 month period i havent notice any coolant leaks.. no coolant burning.. no white smokes ..so where did it go?? i would like some inputs and comments

thanks
Sunny
 

·
Registered
1998 Forester on Orange 57F
Joined
·
4,129 Posts
darkmist2k1 said:
so today i was sitting in traffic not for that long .. and i noticed my water temp started to go up.. i know my engine over heats if i idle for like 30 min because i only have one fan in.. why because the koyo is thicker and i cant fit the fan in...
My car only has one fan and came from the factory like that. It has never overheated with the stock L radiator the WRX radiator or the KOYO race radiator even when it was 110 degrees in rush hour traffic for two hours. I'm going to throw out head gasket or small leak. bubbles in your overflow?
 

·
Registered
'06 LGT
Joined
·
8,334 Posts
Warped heads possibly and you are just burning off excess coolant, but that is just a guess.
 

·
Registered
type RRRRAAAAAA
Joined
·
741 Posts
Discussion Starter #7
hmm i dun think its the head nor the HG.. i took out the engine got a rebuild.. since i went turbo.. new cometic gasket with copper HG spray.. the head was fine.. clean and inspected.. and for my fan.. it doesnt really want to turn on.. for some reason.. is it because i dont have the two fan plug in?.. it only turn on when i have AC on..
 

·
Registered
1998 Forester on Orange 57F
Joined
·
4,129 Posts
darkmist2k1 said:
hmm i dun think its the head nor the HG.. i took out the engine got a rebuild.. since i went turbo.. new cometic gasket with copper HG spray.. the head was fine.. clean and inspected.. and for my fan.. it doesnt really want to turn on.. for some reason.. is it because i dont have the two fan plug in?.. it only turn on when i have AC on..
The AC is generally high speed and runs on a seperate relay. Check the connections and relays to make sure they work
 

·
Registered
1996 custom impreza wagon
Joined
·
323 Posts
i thought with cometic gaskets you arent supposed ot use any sort of hg spray or gasket maker
 

·
Registered
type RRRRAAAAAA
Joined
·
741 Posts
Discussion Starter #10
not gasket maker.. or gasket material.. its copper gasket sealant! and i was told for cometic u should highly use copper spray cause with out it will blow ...
 

·
Registered
Joined
·
414 Posts
Multi meter, or apply 12v power to it, if it clicks on its good, if it doesn't it's bad. Do you have blown fuses? Your fan not coming on would be a bad thing an relying on the AC fan for cooling at idle probably isn't working out so well.

If your fan does not kick on then you will overheat... if your car has been like this for a while, chances are you have been losing coolant to your overflow bottle, OR you have warped your heads, because you overheated and you are losing coolant there too.

OR when you rebuilt your engine, you didn't redeck the heads, or they were torqued imporperly... Basically, you are probably in for resurfaced heads and new HG.

Hopefully it is simple. but if you are out of coolant, I would start looking at the heads.
 

·
Registered
type RRRRAAAAAA
Joined
·
741 Posts
Discussion Starter #13
i check the car again.. fill it up like half a gal of coolant.. there is no coolant residue or leaks near the head.. i havent got a change to check the relays but will do it soon!

after 20 min drive doing errand... i pop my hood open and if i put my nose close to where the turbo is.. i can smell the sweet scent.. so i think somewhere near the turbo
 

·
13 Years of RS
2005 Toyota Corolla :(
Joined
·
5,537 Posts
Could be an internal coolant leak in the turbo itself, even. No white smoke though, so maybe not. Are you just going on what you can see, or have you had somebody follow you and tell you there was no white smoke? Sometimes it can smoke a little, but you won't notice it looking in the mirror. But hopefully it's just an external coolant leak at the turbo, that would be very nice!
 

·
Registered
1998 Forester on Orange 57F
Joined
·
4,129 Posts
HondaH8er said:
Could be an internal coolant leak in the turbo itself, even. No white smoke though, so maybe not. Are you just going on what you can see, or have you had somebody follow you and tell you there was no white smoke? Sometimes it can smoke a little, but you won't notice it looking in the mirror. But hopefully it's just an external coolant leak at the turbo, that would be very nice!
Internal coolant leaks are not very likely. Even with blown turbos. The coolant is pretty much sealed away from everything. You should be able to see it dripping off something if it is disappearing that fast.
 

·
Registered
type RRRRAAAAAA
Joined
·
741 Posts
Discussion Starter #16
yea i had someone followed me as well today.. no white smoke! i think is the crush washer between the collant hardpipe.. i reused it when i flip the hardline around..
 
1 - 16 of 16 Posts
Top