Subaru Impreza GC8 & RS Forum & Community banner

1 - 19 of 19 Posts

·
Registered
2005 RSC
Joined
·
1,131 Posts
Discussion Starter #1 (Edited)
What's my brake light for?

The brake light on my car comes on for no reason unless it serves more than one fuction. The brake like comes on when the E-Brake is on, but it will also come on when get on it a little down the highway. Anyone know why the brake light would come on because I'm stumped.
 

·
Registered
2005 RSC
Joined
·
1,131 Posts
Discussion Starter #3
pads look fine and fluid is good; though it's probably a good to to change it. My rotors are warped. When did the brake light also mean you have brake issues?
 

·
ok terrific.
'95 STi RA rep, rhd yo!
Joined
·
5,208 Posts
Yes. There is a sensor for your e-brake, and there is a brake fluid level sensor, both of which will trip the light.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,291 Posts
It doesn't know the condition of the fluid, it measures the level. Sometimes the float or sensor will go bad causing false readings, but probably just a low fluid level which is why accerating moved the float enough to trip the sensor.
 

·
Premium Member
Donk It.
Joined
·
1,696 Posts
My brake fluid reservoir has to be TOPPED OFF to get the brake warning light to go off and stay off through spirited driving. Literally like almost overflowing.

Aside from that, if continuous high revs cause the light to come on, it may be something with your brake booster or vacuum lines. Experiment with engine revs and fluid level first.
 

·
Registered
2005 RSC
Joined
·
1,131 Posts
Discussion Starter #8
the fluid as been in there 45,000+; it's in need of changing anyway. I'll experiment with it to see what happens; the fluid right now side directly in the middle of the High and low marks...like this:

high||||||||fluid level||||||||low


fluid level being where mine currently is at
 

·
ok terrific.
'95 STi RA rep, rhd yo!
Joined
·
5,208 Posts
Try unplugging the sensor on your master cylinder reservoir and see if the light goes off. If it does, your problem is most likely the mentioned faulty level sensor.
 

·
Registered
2005 RSC
Joined
·
1,131 Posts
Discussion Starter #10
the light doesn't stay on; it'll usually come on when I get on the gas. usually when I accelerate pretty quickly. I'm guessing that when the fluid shifts backward when I get on the gas it trips the sensor. usually when it's cold outside it'll stay on constantly though.
 

·
Premium Member
2002 Subaru Impreza 2.5RS/AW
Joined
·
479 Posts
my 4runner did the same thing.it would come on whene i hit the gas,and would stay on when it was cold.my fluid level was good but,but i filled it to....HIGH|<here>||<it was here>|||||||||||||||||||||||||||LOW and it never did it again.
 

·
Premium Member
Donk It.
Joined
·
1,696 Posts
BRAKE, B-R-A-K-E fluid. Please?

Also, to change brake fluid you'll need to know how/be prepared to bleed your brakes. There's a how-to over on scoobymods.net.

It's not hard, but if you do it wrong you won't be able to stop.
 

·
Registered
'01 RS
Joined
·
136 Posts
impreza2002 said:
my 4runner did the same thing.it would come on whene i hit the gas,and would stay on when it was cold.my fluid level was good but,but i filled it to....HIGH|<here>||<it was here>|||||||||||||||||||||||||||LOW and it never did it again.

My Tacoma did the exact same thing. Just traded it in for an '01 rs yesterday. First post!!! I almost cried when I dropped my truck off. =p
 

·
Premium Member
2002 Subaru Impreza 2.5RS/AW
Joined
·
479 Posts
pballer755 said:
My Tacoma did the exact same thing. Just traded it in for an '01 rs yesterday. First post!!! I almost cried when I dropped my truck off. =p
i traded my 4runner in for my suby,then later had to take it to the dealers sevice department(45 min drive to another town)a month later.i pulled out the other end of the service area and see my old 4runner covered in mud waiting to be serviced.i almost cried remembering how much fun that thing was.and it kinda pissed me off that someone else had been havin fun with it.i had to stop and take a picture.

sorry for goin off topic.
 

·
Registered
99 Aspen White Coupe
Joined
·
443 Posts
Not exactly your problem, but I had something similar with my Nissan once. Both the brake and battery light came on at once and stayed on. Apparently that translates to "bad alternator" in Nissan speak. What brakes have to do with that, I will never understand.
 
1 - 19 of 19 Posts
Top