Subaru Impreza GC8 & RS Forum & Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i replaced it supposedly NEW 1 year and 4 months ago, i barely drove it
i took it to mechanic today, he said my driver rear side is adjustable and the passenger rear side is not adjustable, its stuck, because only one side is adjustable and working and not BOTH sides, the E-brake isn't able to hold the car up on a slope

what could be the problem? anybody know?

i will be taking it back again to take it apart and have it looked at

thanks
 

·
I kill threads!
2000 Ver 6 STI - 1996 Gravel Express
Joined
·
3,749 Posts
Adjust the e-brake shoes and e-brake cable. If you can't adjust the e-brake shoes, fix that. Then adjust it.

Me personally, if one e-brake shoe adjustment is stuck, I'd just take apart the whole e-brake system, clean it up. Grease what needs greasing, then put it back together. Make sure everything moves as it should. Adjust the shoes, slap everything back on, and test it out.

The only things I can see being wrong.

1. ebrake cable needs to be adjusted
2. ebrake shoes need to be adjusted
3. ebrake system under the rotor is seizing up. Needs to be taken apart, cleaned up, greased, put back together
4. ebrake shoes need to be replaced
5. ebrake cable needs to be replaced
 

·
Registered
2000 2.5RS/C BRP
Joined
·
2,321 Posts
It's also possible the pads the shoes ride on are rusted through and the shoes get stuck on them. The adjuster wouldn't be able to change anything then.
 
1 - 6 of 6 Posts
Top