Subaru Impreza GC8 & RS Forum & Community banner
1 - 13 of 13 Posts

·
Registered
2002 PSM WRX, 1999RS Black
Joined
·
840 Posts
Discussion Starter · #1 ·
Hey everyone!

So I just rotated a Precision 5031 turbo on my 2002 wrx. I have my crankcase going into a catchcan breather, my pcv is going to another catchcan breather can. I am having starting issues now. I primed the turbo before startup so I made sure it was oiled well enough, then turned the key and the car is real choppy and will shut off if I dont constantly giving it throttle. I smell a very potent fuel smell after it starts up. I am really thinking this is MAF related. My MAF housing is 2.5 inches from a Injen CAI which is rigged up for now until I get one made at a shop. The fuel purge valve off the intake manifold is plumbed back into the intake and I am running a draw through intake setup still. I have been looking through all the intercooler piping to make sure there are no leaks and have been going through the whole motor for any loose connections with no luck. I do have 1000cc injectors which I ran on my vf39 setup brior to this one. I went in my UTEC to look over some readings and I am just stuck. I have checked all grounds and reconnected all the main sensors. Can anyone give me some info? Thanks so much!!
 

·
Registered
V3 RA Brighton my96
Joined
·
200 Posts
Do you still have your bov connected right? Sounds like a hole in your charged pipe. And if you have any air getting in or out of the system after the MAF it will do that.
So ensure all the hoses are hooked up right. And all holes plugged.
 

·
Premium Member
2001 2.5RS-T BRP
Joined
·
575 Posts
Maybe post a couple of engine bay shots and someone may spot something. Sure sounds like an MAF problem or post. What are your fuel trims doing while this is happening?

It would be a good idea to pressurize the intake and check for leaks. It's pretty easy to make a tool for this from PVC, you just need a compressed air source.
 

·
Registered
2002 PSM WRX, 1999RS Black
Joined
·
840 Posts
Discussion Starter · #6 ·
Sorry I havent updated any. I have been trying to figure this out. I am in the process of doing a blow through setup now since I cant get it to run right. I got it to drive but as soon as I go 10% throttle, it goes super rich and stalls. I cant seem to keep it driving. It idles perfect now
 

·
Registered
98 impreza
Joined
·
68 Posts
Pics of the setup would help too. If your blow through set up is backwards, you'll have these kind of issues. Bov leak or unregulated fuel purge will cause you to run rich too.
 

·
Registered
2002 PSM WRX, 1999RS Black
Joined
·
840 Posts
Discussion Starter · #12 ·
Just deleted my TGVs in my garage and capped all the emissions crap up on the manifold! Now I need to order some valve cover gaskets and spark plug grommets.
 

·
Registered
Joined
·
1 Posts
Hey everyone!

So I just rotated a Precision 5031 turbo on my 2002 wrx. I have my crankcase going into a catchcan breather, my pcv is going to another catchcan breather can. I am having starting issues now. I primed the turbo before startup so I made sure it was oiled well enough, then turned the key and the car is real choppy and will shut off if I dont constantly giving it throttle. I smell a very potent fuel smell after it starts up. I am really thinking this is MAF related. My MAF housing is 2.5 inches from a Injen CAI which is rigged up for now until I get one made at a shop. The fuel purge valve off the intake manifold is plumbed back into the intake and I am running a draw through intake setup still. I have been looking through all the intercooler piping to make sure there are no leaks and have been going through the whole motor for any loose connections with no luck. I do have 1000cc injectors which I ran on my vf39 setup brior to this one. I went in my UTEC to look over some readings and I am just stuck. I have checked all grounds and reconnected all the main sensors. Can anyone give me some info? Thanks so much!!
hello i have the same exact problem! What was the issue that car wont start? Thanks!
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top