Subaru Impreza GC8 & RS Forum & Community banner

41 - 42 of 42 Posts

·
Registered
1999, RS, Silver
Joined
·
49 Posts
I had the same problem happen to me about a year ago up here in Ft collins, CO but I got a new rad cap and it was fine, but it recently started doing it again for example the other day on the highway my engine started to overheat and noticed that my res tank was completely full, but after a few minutes the reserve tank emptied it's fluid back into the radiator, and it was fine for the rest of the drive. What could this be?? I tested the thermostat and rad cap and they are fine so maybe a head gasket problem?
 

·
Registered
Joined
·
1 Posts
K I had the same issues most of u had,interior heat stops-temp gage goes up-reservoir fills,-wait a few minute limp home and stop wait and go again,
tested coolant for hydrocarbons with Blue line tester and nothing (multiple tests) water pump is fine idles in driveway on ramps for 5 hrs and temps stay normal, we we're scratching our heads. not coolant in oil,no white smoke from exhaust.
finally used a coolant filling system.i.e. funnel with adapter to take place of rad cap,funnel has a stopper in it to seal system to get pressure up in system, revving engine to clear an airlock,many times,after about 2 hrs air stopped bubbling into funnel.
I have never in my years dealt with an airlock like that .1999 outback 2.5 DOHC is running fine now,temps r rock solid. tomorrow getting Subaru cooling system conditioner ,$6 insurance and also replaced rad cap,the cap was faulty and caused air to leak into system
 
41 - 42 of 42 Posts
Top