Subaru Impreza GC8 & RS Forum & Community banner

1 - 8 of 8 Posts

·
Registered
2001 Subaru Impreza rs 2.5
Joined
·
4 Posts
Discussion Starter #1
Hey folks!

I have a 2001 Subaru Impreza RS 2.5.
It's a five speed manual all wheel drive.
The only thing I've done to it is intake and exhaust.
I think I have a water pump issue but I'm not sure.
I'll post a video on here shortly and see if it may be the valves.
I am hopeful it isn't that but I'm not sure until I
Attempt to fire it up.

If you have any suggestions please email me @
[email protected]
Or directly on here.

Thanks,
Jaymz
 

·
I kill threads!
2000 Ver 6 STI - 1996 Gravel Express
Joined
·
3,749 Posts
Won't know anything with that video or at least a description of the issues.
 

·
I kill threads!
2000 Ver 6 STI - 1996 Gravel Express
Joined
·
3,749 Posts
Car may or may not start. If it does start, it's going to be making a super loud ticking. May or may not idle, won't run right, sucks gas, a lot of symptoms.

Either way right now it's completely pointless for any of us to say what is or isn't wrong with the car, when you give us absolutely zero description of what your problem is.
 

·
Registered
2001 Subaru Impreza rs 2.5
Joined
·
4 Posts
Discussion Starter #5
Well I'll start at the beginning.

It started to overheat but only at an idle. If I revved up a little it would eventually come back down to temperature. So I figured it might be a sticking thermostat or a water pump. I looked at the timing belt and everything checked out. As of now I'm just trying to get the battery charged and fire it up.

That's where I'm at.
 

·
I kill threads!
2000 Ver 6 STI - 1996 Gravel Express
Joined
·
3,749 Posts
I'd work in this order.

1. Check coolant level and top off. See if fixed.
2. Burp system, top off coolant. See if fixed.
3. Replace thermostat, fill coolant, burp system, top off coolant. See if fixed.
4. Replace water pump.

Now while checking coolant and stuff, make sure you don't see any oil in the coolant or coolant in the oil. Since it just overheats at idle, I doubt it's a blown headgasket, but might as well just look.


Edit:

I had this same issue with my car and it was nothing more than low coolant. When you went idle, the temps would skyrocket almost to the red. As soon as you started moving again, it'd drop right back down into normal ranges. I thought it was a thermostat issue, so I ordered one up, not even bothering to check coolant.

It only got worse after that, I started getting hesistation issues around 4500 rpm. Soon as I put in more coolant, all went away. Still got my new thermostat sitting in a box.
 

·
Registered
2001 Subaru Impreza rs 2.5
Joined
·
4 Posts
Discussion Starter #7
I'll do that. If I come across anything else I'll be sure to post it here.
 

·
Registered
00'RS/02' WRX stgEleventy
Joined
·
2,144 Posts
Low coolant... hear any water wooshing sounds when you rev the car?

Sent from an other planet (Tapatalk)
 
1 - 8 of 8 Posts
Top