Subaru Impreza GC8 & RS Forum & Community banner

21 - 40 of 110 Posts

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #22
I got the headliner installed tonight. It was kind of a pita; mostly awkward positioning and repetitiveness. Cutting out the hole for the roof scoop trim was cut, test fit, cut, test fit, repeat for 30 minutes. So far I would say it looks ok. The holes where the oh S! bars and hangar hooks are open which looks rather meh. I didn't get the dome light installed though. There's no hardware to mount it to so I'll have to think of a way to install it. I had initially thought about velcro but there's a 2 inch gap or so from the headliner to the roof skin so that probably won't work out too well.
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #23
Awesome news! /sarcasm I curbed a wheel today! I've been a grumpy mofo since.


I'm going to grab some rear headliner clips for it tomorrow. For the open holes of the oh shit bars and hooks I'm thinking I might be able to use the "blank" clips that are used on the driver side of an RS. I'll have to check into that some more though.
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #25
Thanks, yeah I remember you. Your brother or cousin was going to buy an RS too, right?
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #28
car looks great... totaly my paint scheme though lol!!!! black engine bay charcoal on the outside. l
You have good taste sir!
yeah he bought one n going to every meet
Sweet!

I stopped by the stealership today to order the rear headliner clips and the side "blank" clips. They didn't have them in stock so we should see later this week.
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #29
I took some pics of the headliner with the dome light installed. The dealer called and the 4 rear clips are in. I'll pick those up tomorrow if they're open. They couldn't figure out the "blank" clips that go on a typical driver side instead of the o shit bars. I figure I'll just install 8 of those to cover up the open holes. I also need to source two more of the plastic screw/clips for the roof vent shroud. You can spot a future upgrade lurking in the background.





 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #30
What's the standard whp increase for this mod? I'm thinking at least 10. (it's the red hazard button btw)

 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #33 (Edited)
A couple pics from the crazy ice storm in Renton earlier this week.

Tree near where I parked my car:



After 15 min warmup, 45 min commute and 2 hours in the garage:








 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #36
do you live in the northgate area? ive seen you a couple times i think. im in the mismatched wagon :lol:
Yeah, I live in Wedgwood but I'm in the Northgate area somewhat frequently.

awsome setup mate...
Thanks!

I'm hoping to get some upgrades going here in the next couple weeks. I'll try to update this as I do (haven't been online here much lately).
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #37 (Edited)
A good and bad weekend. I took the car in for a 30k service. I thought I had stripped out a lug nut prior to taking it in. I had tried to take the other lugs off so I could get a dremel in to cut the stud, no dice. It turns out I was running lugs that weren't completely seated. The wrong size wheel studs were installed by the previous owner also. So the splines in the hub ended up getting stripped. :bonk: New hub it is! All the studs are getting replaced tomorrow. I had an intuition that something was not right. It turns out that was the case. Sigh, not a huge issue but I really put a lot of pressure on myself for issues like this. I should know better, I need to be better. Frustrating.

On a good note I autocrossed it for the first time on Sunday (way overdue). No issues except I had forgotten about the fuel starvation issues in the RS's on RH turns. The last turn on the course was a long RH hairpin so I limped across the line every run. I wasn't out to set FTD, and I don't have the skill to anyway, but another issue I should know to actively avoid. It's been way too long since I've been to the track.

I've mentioned some future upgrades. I need to get off my ass and complete one that I've had on the shelf for a while now. I don't know if it's age but I move a lot slower than some enthusiasts on this board. I respect them for the 'all in' mentality. I guess I just can't do that anymore. I want to always maintain stage zero before spending any effort to up a stage or add upgrades.
 

·
Registered
'00 RS | '05 Legacy
Joined
·
577 Posts
Discussion Starter #39
I bought a camera mount for autox. I was 50/50 on heading to Packwood tomorrow. I'm rethinking that due to the weather though; terrible the last two days. Anyway, here's a quick video testing it out. It's nothing exciting. I do a quick 2nd gear pull ~2:30 towards the end. Otherwise it's nothing to write home about; just testing it out.

 

·
Premium Member
991 GT3
Joined
·
503 Posts
Awesome video and sounds really good! I'm actually pretty embarrassed about those studs, I bought them from RallySport Direct which I was told they would work; sorry to hear that wasn't the case... I hope all is well other than that and I can't wait to see it get a 6mt :) Take care!
 
21 - 40 of 110 Posts
Top