Subaru Impreza GC8 & RS Forum & Community banner
1 - 12 of 12 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
So, I had my dash out of a project that I was working on, and when I put it back in my turn signals stopped working. I'm thinking that I just forgot to plug something in, but I don't see any loose wires. Oh, the car is a 2000rs. I also just put in a ver. 6 STi cluster, but the signals were already not working when I put it in. Any help is appreciated

Thanks
 

·
Registered
2017 STi
Joined
·
9,572 Posts
So, I had my dash out of a project that I was working on, and when I put it back in my turn signals stopped working. I'm thinking that I just forgot to plug something in, but I don't see any loose wires. Oh, the car is a 2000rs. I also just put in a ver. 6 STi cluster, but the signals were already not working when I put it in. Any help is appreciated

Thanks
My one HL was burned out not too long ago and I couldn't figure out what it was for like a week. Turns out it was a simple llittle blown fuse :rolleyes:
 

·
Registered
2017 STi
Joined
·
9,572 Posts
LOL It's alright. I felt pretty dumb when I found out mine was caused by a blown fuse
 

·
Reformed Ricer
07 STI, 07 STI, 10 Forester, 03 WRX
Joined
·
4,575 Posts
So, I had my dash out of a project that I was working on, and when I put it back in my turn signals stopped working. I'm thinking that I just forgot to plug something in, but I don't see any loose wires. Oh, the car is a 2000rs. I also just put in a ver. 6 STi cluster, but the signals were already not working when I put it in. Any help is appreciated

Thanks
im going to answer your question with another question:

how well does the STi gauge package mount up in the RS dash? mine is a year older than yours, i'm not sure when the body had that giant facelift. so yeah, any help from your end would be appreciated. =]

but if i find a cluster and my turn signals stop working too ill let you know.
 

·
EEEEP!!!!
Something Slow
Joined
·
2,000 Posts
Your blinkers are wired through your hazard button, without it the blinkers dont work. Plug it in and try again.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #10 ·
Got it. The hazard wiring fell into the mess of wiring under the dash so that's why I didn't see it/remember it. I still feel pretty stupid. Here's a peek at what I had the dash out for:



 
1 - 12 of 12 Posts
Top