Subaru Impreza GC8 & RS Forum & Community banner

1 - 20 of 31 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
I'm testing out a rear O2 sinulator that will get rid of this problem for all of us. It is made by ECG Performance Electronics and I believe it's $35. When I get it all done and tested, I'll post a review and contact information for the guy that I got it from. Hopefully it'll keep a whole LOT of us from having to deal with that CE light anymore. :)
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
hopefully this fixes the problem...we'll find out tommorrow ;)
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
we didn't get a chance to do the install today...other things took longer then expected. Will have to try and fit it in tommorrow.
 

·
Registered
Joined
·
170 Posts
Discussion Starter #7
Heh, I know both of those feelings. I'll get it installed tomaro when the sun is out... felt like crap when I woke up today so it's going to be a slow day.
 

·
Registered
2000 Subaru Impreza W"RS"X BRP
Joined
·
189 Posts
Still there...

Well, I swapped back to my stock exhaust manifold from the borla header and I still threw the CE light...So, it has nothing to do with the Borla header...With a TEC 2, will I still throw CE lights?

Zee:sunny:
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
Re: Still there...

Sunrise City Rider said:
Well, I swapped back to my stock exhaust manifold from the borla header and I still threw the CE light...So, it has nothing to do with the Borla header...With a TEC 2, will I still throw CE lights?

Zee:sunny:
well seeing as how the factory ECU will no longer be able to control OEM sensors i will have to say yes. Also have you checked the code and or your gas cap recently??
 

·
Registered
2000 Subaru Impreza W"RS"X BRP
Joined
·
189 Posts
Not the gas cap

I know it has nothing to do with the Gas cap, but I never did get the code read either...I will though this coming week...

Zee
 

·
Registered
Joined
·
170 Posts
Discussion Starter #11
Re: Still there...

Originally posted by Sunrise City Rider Well, I swapped back to my stock exhaust manifold from the borla header and I still threw the CE light...So, it has nothing to do with the Borla header...With a TEC 2, will I still throw CE lights?
How long did you give the ECU to realize that you had swapped back? The most common cause of the Borla's to throw a CE is because the exhaust gasses have cooled down too much and are making the A/F ratios wierd all around. Supposedly header-wrapping them will fix it from what I've heard.

The TEC-II won't throw a CE light no matter what, I believe.
 

·
Registered
2000 Subaru Impreza W"RS"X BRP
Joined
·
189 Posts
Well, I sold them and went back to my stock cast iron manifold since I am expecting to run a Garrett GT series Turbo with TEC2 engine management in January and the Borla Header will be to weak to support the turbo...plus I need the dough and I figured the Stock Manifold isn't gonna make too much difference than the Borla...Since neither of them are equal length headers anyway...I will get a nice manifold made if Shiv doesn't come up with one to match his kit...but thats another story...
I haven't changed the Oxygen sensor yet and I drive a MY00...The dealer that is local, Eddie Accardi, makes my blood boil and I cannot bring myself to even step to them...I will lose it...I already tried and did...I don't think I really need to stress it, as everything else is normal...I'll just head to West Palm and check out Delray Subaru for the recall...

Zee:boxer:
 

·
Registered
Joined
·
170 Posts
Discussion Starter #14
Ok, I got it installed yesterday afternoon and have been putting it around and checking the voltages with an OBD-II scanner. Everything looks like it's going to be absolutely perfect. I still have to go the damn 300 miles to be 100% sure that the catalyst effeciency code doesn't throw (damn, wish there was a way to force it to test... or be like a Honda and just test it once it hits a solid 55mph all the time).

For now, the product has my full thumbs-up though. :) More details as soon as I get the catalyst test finalized.
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
Re: Re: Still there...

Hndatch627 said:


well seeing as how the factory ECU will no longer be able to control OEM sensors i will have to say yes. Also have you checked the code and or your gas cap recently??
I was talking with 8 about this last night and i was under the impression the TEC-II was standalone but he made it sound like it's more of a Piggyback...well anyhow i forgot that when you unplug the Engine side of the harness you unplug the MIL as well....well anyhow i guess the stock ECu still have some controls so there would be no MIL.

okay back on OT...i was asking 8 tonight if the maker has put in a resistor so that the secondary O2 can be eliminated completely, didn't sound like it has been thought about but it seems to be working normally...we'll have to see.


Hey 8 did you see if the diag monitors had run yet cause it takes a 2 trip failure to light the MIL but there will be a DTC stored. Check it out.
 

·
Registered
Joined
·
170 Posts
Discussion Starter #16
Re: Re: Re: Still there...

Hndatch627 said:
okay back on OT...i was asking 8 tonight if the maker has put in a resistor so that the secondary O2 can be eliminated completely, didn't sound like it has been thought about but it seems to be working normally...we'll have to see.

Hey 8 did you see if the diag monitors had run yet cause it takes a 2 trip failure to light the MIL but there will be a DTC stored. Check it out.
Yeah, I think you have to have a second sensor in-line, or put a resistor in there if you want to have absolutely NO rear O2 sensor. *shrug* Most of us just want to fix that damn CE light anyway, and already have rear O2 sensors installed.

I thought that it ran the catalyst check 300 miles into it. What are you talking about with DTC's? Gonna hafta call you tomaro and ask you about it. I'll go scan the car again in a few minutes and see if anything is completed, but I doubt it.
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
DTC=Diagnostic Trouble Code...even if the MIL(CE Light) is not on there can BE a DTC stored in the ECM/PCM...you just have to see if the diagnostic monitor has run.
 

·
Registered
2000 Subaru Impreza W"RS"X BRP
Joined
·
189 Posts
Aye Whassup Essaaayy...

8, yo, you have what gauges in your ride? What numbers are coming up? Where are the gauges positioned? I'm only asking all this crap 'cause I need to figure where to put what gauges...ie..the important gauges where I don't have to move my eyes from the road much...I have plenty of small gauges...2 1/16" and 2 5/8"....All Autometer Phantom....Oh and you are sure that the ECU doesn't throw a CE when running the TEC? I should ask someone in Vishnu but I rather ask you...

Zee:stupid: :D
 

·
Registered
Joined
·
170 Posts
Discussion Starter #19
I'm about 95% sure that the TEC-II kit won't allow a CE light to be on. Don't know for sure because I haven't looked into it that detailed.

I am running Boost, EGT, A/F, and Fuel Pressure. Mine are all mounted in a custom panel where the radio used to be. Not recommended for those that want to look at them quick though, I just have trained myself to know by checking them out with the corner of my eye.

Can't say on the numbers coming up... I'm still NA right now because I want to get my fueling down before anything else.
 

·
Registered
Joined
·
30 Posts
When you install the Tec-II, you cut the wire from the stock ecu to the CE light. You can hook the CE light up to the Tec-II and program it for when it should go off.

That is what I gathered from reading on the Vishnu forums.

Aaron
 
1 - 20 of 31 Posts
Top