Subaru Impreza GC8 & RS Forum & Community banner

1101 - 1120 of 1743 Posts

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,103 (Edited)
so you're not gonna put an ebay strut bar over the bed???
negative.



I drove it around a bit last night. Had to pull over to adjust headlights which just fell back down again. Rode pretty well for have no adjustments yet. I felt a little something on a hard corner, not sure if bump steer or what. I wasnt focused on handling, more so on it not falling apart and nervous about popo's since i didnt have wallet or and insurance ID or anything with me. I also still need to get my better engine mounts. Since i dont have a dogbone i wanted to get a Torque Solution type that limts fore/aft movement

 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Hope it doesn't rain Congrats though, bet its a good feeling being able to drive that thing. Have you tried going really fast really quickly yet? Lol

Sent from my SM-G935F using Tapatalk
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,107
Hope it doesn't rain Congrats though, bet its a good feeling being able to drive that thing. Have you tried going really fast really quickly yet? Lol

Sent from my SM-G935F using Tapatalk
ha no. couple little spurts but nothing over 50% probably. Its on pump gas now cause of temps. I never really tuned it on pump gas. Just going off the default carberry corrections. It works but not optimal. And my wideband was just flashing 7.35. sometimes it doesnt connect with gauge right
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,109
What wideband do you use?
Innovate LC2. Its older now, could be wiring could be the old sensor. I think its usually a heater issue when it flashes 7.35. The odd thing with my car though with the SF wiring GD ecu swap. If i turn key off, most of my gauges stay on for like 5-30 more seconds. Somehow i think i used and old o2 feed or something for my switch 12v. So a quick ignition off reset doesnt work for my cruising down road unless i leave key off for up to 30 seconds
 

·
Registered
Turbo, LS swapped Impreza RS
Joined
·
5,169 Posts
That's interesting but I don't think it is a wiring issue in your end. I wired my gauges to a radio switched feed and they had the same 20-30 second shut down delay. They would also have a 5 or so second delay before coming alive.
 

·
Registered
Turbo, LS swapped Impreza RS
Joined
·
5,169 Posts
Should make them look like an 80s disco advertisement. All the pink, blue, and yellow you can get.

Sent from my SM-N920V using Tapatalk
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,116
Took it to homedepot yesterday came out to a small crowd. Same thing leaving work the other day. Im not a real outgoing talkative person in person so its a bit weird so far. Taking it to chucky cheese gonna be a nightmare.
 

·
Registered
Cheap Kitchens
Joined
·
1,875 Posts
Write a FAQ on one of the plexi panels

It is powered by :projectsti.com:
Yes it is legal
Yes I built it myself
Yes it is insured
Yes perf, seriously
Yes it is fun to drive
Yes I drive my kids in it
No you can't drive it
No plans for ebay strut brace
No I did not do donuts at chuck e cheese, that was another tube truck
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,119
Write a FAQ on one of the plexi panels

It is powered by :projectsti.com:
Yes it is legal
Yes I built it myself
Yes it is insured
Yes perf, seriously
Yes it is fun to drive
Yes I drive my kids in it
No you can't drive it
No plans for ebay strut brace
No I did not do donuts at chuck e cheese, that was another tube truck
ha. thats actually pretty funny. I was planning some sort of Powered by Subaru thing
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #1,120
I got a vibration at 80 mph thats been bugging me. Im pretty sure it exhaust resonating in the magnaflow muffler. So now i want to rubber mount my entire exhaust but its tight next to trans. Im thinking i can maybe solid mount it to trans since its got a rubber mount to chassis?

the vibration happens in 3rd and 4th gears as well all around the same 3200-3500rpm range
 
1101 - 1120 of 1743 Posts
Top