Subaru Impreza GC8 & RS Forum & Community banner

121 - 140 of 1537 Posts

·
Registered
2002 OBS / 2008 FXT
Joined
·
387 Posts
I just reread the thread, hmm maybe the potential blowby is fouling the plugs and causing misfires? Doesn't make a whole lot of sense in that all are doing it, but you never know. Misfires can be a bear to track down the problem.

Sent from my DROID RAZR HD using Tapatalk
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #122
My blowby is routed to my downpipe. My intake is spotless. I did a little more logging this morning and my MAF signal is a lot rougher than usual on the pulls that were "missy". I dont know if its the cause or the effect yet but tonight i might try rotating the housing, I just cleaned the sensor the other day when i redid my map scale. Since i rescaled the car has run much smoother in closed loop but now open loop is sloppy so it could just be a bad fuel cell. I adjusted a little but i was in traffic so I'll have to wait and relog to see if it helped.
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #123
The misfire seems to be getting worse. I thought it could have been knock so i pulled a couple more degrees of timing with no change. My plan is to change out my BRK6 plugs for BRK7 since i about tripled my 2.2's factory horsepower. I'm getting the NGK blue plugs for a 96 Legacy. I have 97 wires on it that dont completely cover the hole on the 96 heads so maybe water is getting in. And i may just buy a new coil pack too for good measure.

If this doens't help I'm going to run better grounds and then start suspecting the clutch for slippage
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #124
Turns out my stuttering was from tuning issues. I rescaled my fuel map for better resolution where i need it and i guess i messed it all up. The ecu's maf signal is so linear that between 4 and 4.5 volts there is as much air flow change as between 1 and 4 volts. I'm done a couple ponies but I think i can get my AFR's flattaned back out and should get up over 340whp. I dont think the VF43 is going to be good for much more, its been struggling to keep up at 20psi

 

·
Registered
GF OBS-T, GM RS EJ20, SF EJ20
Joined
·
4,973 Posts
This set-up should kick some ass on the drag-strip you should make a few passes I'm thinking 12's should not be a problem...
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #129
I can't find any info on other Foretser. I might just be the worlds fastest Phase One Forester!

Now i just need a 1/4 mile slip to prove it.
 

·
Registered
2001 D2 A8L
Joined
·
928 Posts
When I was reading about your misfire issues at higher boost my first instinct was coil pack. Sounds like you were able to fix it though.
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #131 (Edited)
It's not really fixed, i just turned the boost down to 15psi.

I think i narrowed it down to my turbo. It's beat. Its getting shaft play and the cold side wheel has been rubbing on the compressor housing, i think enough to wear it down and not be able to hold boost up top. My misfires may have been coming from the eractic MAF signal from the compressor surge. The VF43 has had compressor surge ever since i went blow through MAF and eliminated the IAC boost leak.

Its running good now and will probably stay at 15psi until i finish my next build and add a yet to be decided turbo
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #132
Engine failed.

But its cool. I have more blocks, my heads could use refreshed anyway. I have another 2.2 block but want to put sti rods and wiseco pistons in it. I have a 253 block that i might put sti stuff in for now
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #135
It started smoking at wot a couple weeks ago after i pushed it hard and lean at 25psi. I thought it was ok but i must have cracked a ringland, since then its been rougher at idle. Then this morning that hole side of the piston must have finally let go. It was an old motor so im not surprised. Im gonna start pulling it apart this weekend. Heads need valve seals and some lapping, 253 needs honed to accept the sti pistons. And some uppipe flange work. Turbo rev 2.0 should be a better runner but might only go up to 1 bar on it for reliabilty until i build the forged 2.2
 

·
Experimenter
Tubaru Pickup
Joined
·
3,910 Posts
Discussion Starter #139
Bought this car with 236k miles. I know has 265k miles and this will be the 6th engine i put in it
2.5 removed for head gaskets
2.5 snapped timing belt
2.2 leaked oil
2.5/2.2 still good, sold
2.2/2.5 turbo blew rings
2.5/2.5 turbo, under construction.
 

·
Registered
Joined
·
108 Posts
Bought this car with 236k miles. I know has 265k miles and this will be the 6th engine i put in it
2.5 removed for head gaskets
2.5 snapped timing belt
2.2 leaked oil
2.5/2.2 still good, sold
2.2/2.5 turbo blew rings
2.5/2.5 turbo, under construction.
And a partridge in a pear tree!
 
121 - 140 of 1537 Posts
Top