Subaru Impreza GC8 & RS Forum & Community banner
1 - 8 of 8 Posts

· Registered
99 Subaru 2.5 RS ..Gray
Joined
·
47 Posts
Discussion Starter · #1 ·
i just crashed my 1999 gc8 and got a 2000four door rs. i swap the motor out last sunday. the starts up but i have a flashing engine light. i read the codes and it says its a vehicle speed sensor with a bunch of tickigng fuses. now do i replace that or am i missing a ground or fust is blown. everything in my last subaru worked fine like 100%.

if anyone has any opinions that would be great.
 

· Registered
*
Joined
·
473 Posts
i just crashed my 1999 gc8 and got a 2000four door rs. i swap the motor out last sunday. the starts up but i have a flashing engine light. i read the codes and it says its a vehicle speed sensor with a bunch of tickigng fuses. now do i replace that or am i missing a ground or fust is blown. everything in my last subaru worked fine like 100%.

if anyone has any opinions that would be great.
is that the only code? a flashing CEL is pretty serious..
 

· Premium Member
2001 A.W. L
Joined
·
16,492 Posts
Which Intake manifold did you use? When I did my 99 into 00 swap there were some small differences between the two...

Also did you happen to plug the two green plugs under the dash into each other? if you did unplug them ;)

I drive threw rockaway every day on my way to work, feel free to hit me up on PM and Ill stop by one day and see if I can help.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top