Subaru Impreza GC8 & RS Forum & Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Looking For Some Help On My Project 98rs To 05 Wrx Swap Is Complete Everything Works Exept My Spedo Am Using An 00 Rs Cluster But As Soon As I Connect The Spedo I Get A Cel With Low Vss Signal Any Body Had This Problem With Their Swap Any Help Would Be Appreceiated Thanx Paul
 

·
Registered
99' Subaru Impreza 2.5 Rs
Joined
·
3,712 Posts
Need more information. What did you swap? Did you do an 05' gearbox too? Did you change the hubs and abs box? Tell me everything you bought for this swap.

Here is what I can tell you. An 05' wrx is drive by wire. You would have had to swap the pedal box over. The 05' gearbox also doesn't have a speedo gear. It has a gold plate blocking where the speedo gear used to go. The 05's read the speed from the wheel sensor and the abs ring I believe. To be able to add a speedo gear you would have to crack open the case. If you did this I'd also imagine that you'd have to swap over to an 04' wrx ecu not to mention you'd have to convert your engine back over to a throttle cable. The reason I know this is I bought an 05' non turbo legacy trans for my rs and realized this after I had the gearbox in. I drove around without the speedometer for almost a year. I'm currently swapping now and that's the main reason I got an 04'. Hope that helps but still post up a little more information and there might be an easier fix to that.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
swap

thanx for your help ,my car has a complete 05 swap motor trans difs and ecu but kept rs dash and guages,ive added the 00 rs cluster so it would work with the 05 wrx vss signal ,but still nowhere ,my 05 wrx was not drive by wire ,it was cable thanx paul
 
1 - 3 of 3 Posts
Top