Subaru Impreza GC8 & RS Forum & Community banner

1 - 6 of 6 Posts

·
Registered
98 impreza rs black 06 wrx swap
Joined
·
697 Posts
Discussion Starter #1
Yesterday I did some pulls and it was then after some regular driving for 20 min I did a 3rd gear pull from 3.5k and it was acting liking it was choking. I saw the tank was just over half full I put a half gallon of 93 in I had in a tank and took it out back out and did a pull and it was fine. I have a welbro 255 pump that is new I have welbro's sock on it, Fuel filter was replaced last feb only has 5-6k miles on it. I accidentally ran my return line to my evap before and it was pissing gas out the canister. I have no cel but could the canister still be damaged causing this?

98 rs with a 06 wrx swap
 

·
Registered
1995 EZ30 Coupe
Joined
·
515 Posts
Hmm, if I remember correctly, the sock that came with my Walbro 255 had a 90° angle to it so it was flat if the pump was perfectly vertical. However, because the pump sits at a 45° angle in the tank, using the Walbro sock would've resulted in the pump and sock making a "V" in the tank, effectively elevating the sock off the floor of the tank. I ended up using my stock Impreza sock so it would lay flat in the tank. Maybe the sock is allowing the pump to pull some air as the fuel sloshes around?
 

·
Registered
98 impreza rs black 06 wrx swap
Joined
·
697 Posts
Discussion Starter #3
Hmm, if I remember correctly, the sock that came with my Walbro 255 had a 90° angle to it so it was flat if the pump was perfectly vertical. However, because the pump sits at a 45° angle in the tank, using the Walbro sock would've resulted in the pump and sock making a "V" in the tank, effectively elevating the sock off the floor of the tank. I ended up using my stock Impreza sock so it would lay flat in the tank. Maybe the sock is allowing the pump to pull some air as the fuel sloshes around?
My was pointed almost straight down just like to oem was.
 

·
Registered
2001 STM 2.5RS
Joined
·
5 Posts
Yesterday I did some pulls and it was then after some regular driving for 20 min I did a 3rd gear pull from 3.5k and it was acting liking it was choking. .
I accidentally ran my return line to my evap before and it was pissing gas out the canister. I have no cel but could the canister still be damaged causing this?
Yes. Had similar issues on my '01 when the canister crapped out this past summer. Once I was fairly certain this was the case I cut a hole in the top of the canister and drained the charcoal, sealed it shut and continued with my normal commute for a few days to verify. All symptoms went away so I ordered up the Dorman replacement unit for ~$65 and haven't had any issues in the past 4 months (10k miles).
 

·
Registered
98 impreza rs black 06 wrx swap
Joined
·
697 Posts
Discussion Starter #5
Yes. Had similar issues on my '01 when the canister crapped out this past summer. Once I was fairly certain this was the case I cut a hole in the top of the canister and drained the charcoal, sealed it shut and continued with my normal commute for a few days to verify. All symptoms went away so I ordered up the Dorman replacement unit for ~$65 and haven't had any issues in the past 4 months (10k miles).
How'd you check it before cutting the canister open?
 

·
Registered
2001 STM 2.5RS
Joined
·
5 Posts
How'd you check it before cutting the canister open?
Detached the hoses at the canister and took it for a drive. That stopped the issue so I checked all of the lines downstream from the canister to make sure there weren't any blockages. After not finding anything downstream I gutted the canister to verify.
 
1 - 6 of 6 Posts
Top