Subaru Impreza GC8 & RS Forum & Community banner

21 - 40 of 73 Posts

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,740 Posts
You can fit an engine in coupe/sedan trunk. Pull spare tire, remove deck lid, put motor in and then put the decklid back on.
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #23
Yeah the GF was pretty good for hauling


I'm driving my brothers '95 530i right now, pretty sweet ride. Found some control arms from a part out so I'll grab those this weekend, I'm really hoping new wheels and control arms will make it drivable. We shall see. I was planning on rebuilding my 99 EJ25D block with STI stuff for silver, but it may go in the black one instead.

I guess my GM is on the back burner again.:mad:
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #26 (Edited)
Some pics of the carnage.




On the bright side, everything went back together pretty easily and she drives straight and smooth! Just needs more bodywork now. I found a WRX being parted out somewhat locally, and got a good deal on the control arms and the shifter trim. Gonna go back for a few more things; drivers door, maybe windshield wiper motor, and definitely the crossmember.


Oh and some things showed up.🍌

Anyone thing that one big end is a little heavy? Should I ask my machinist if he can balance them further?
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #29
5MT swap completed!

Started at 4pm on Saturday, had it mostly back together last night around 930, and completed a quick test drive to the corner and back. Let me tell ya, when you're used to turning the wheel and hitting the gas only to plow straight ahead, it's SO NICE to blip it and have the ass immediately step out!

This morning I replaced the trans fluid and did some of the wiring, just enough to get it to drive to work. Main issue right now is that I forgot to swap the VSS to the new trans, which has a 2 wire sensor. Without the speed signal my ecu is in limp mode and won't rev past 4.5k.

Here's some random pics I snapped while I was scrambling, let's start with my favorite:

Nice to see that ugly auto shifter gone, never to darken my console again.


Here we have the reason for keeping spare parts. I'm surprised it actually came out.


Honestly thought I was going to lose it trying to get around those trans cooler lines to loosen the bell housing bolts. Slowest part of the job, two bolts and a nut took 2 hours to remove! Should chopped the lines at the start.


Finally the nightmare is over. Installing the manual was a freakin' breeze! I need to tweak one exhaust hanger that intersects the new crossmember slightly, that's it.


Found the reason my radiator fans were randomly cycling while the car was off. Clearly a result of a tire battering the wheel well. Nothing was broken so I just taped em up individually then wrapped em up together and shoved em back up there.

I'm extremely pleased with the response and control my car now has, and the connection to the vehicle... Until now it felt like I was driving someone else's car.

Side note, anyone know if I can just add a stronger weaker spring to the clutch pedal? These hydraulic units are so light, after driving the 'HD stage 2' in my coupe I have trouble letting the clutch out.

:blow_money_original :banana: :projectsti.com:
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #31
This P0500 code is driving me insane. Not sure what triggers it, but seems to be any throttle input over 3k. After that it fuel cuts at 4.5k and throttles up when I let off to shift. Not helpful. I now hit the clutch and coast for a few seconds before engaging the next gear, waiting, defeating the purpose of removing the automatic trans!!! Looking for a 3 wire VSS but no luck yet, so...

Anyone know how I can get the ecu to not look for a VSS? Can a 2 wire VSS be made to imitate a 3 wire VSS? Can I just give it a couple volts to think it gets signal?

Any help greatly appreciated
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #33 (Edited)
So I ended up resolving a bunch of my issues by playing with the neutral position sensor and the 'manual identification pin'. Now I've got a relay basically inverting the operation of the NPS because mine is a legacy trans and it's backwards, and the car drives like a standard should drive from the factory. Mostly.

My theory:
When I engine brake, the rpms are somewhat sustained thanks to the transmission, despite zero throttle input. Without a vehicle speed signal, I believe the ecu interprets the higher than idle rpms as an issue with the idle air control valve. It throws a 1508 (IACV) and tries to stall out when I clutch in after long periods of engine braking because it's trying to close the IACV as much as it can, which it turns out is enough to stall the car. Anyways, it's PERFECT if I don't engine brake.







...And I need to get rid of it. I found what I hope to be my forever daily:
1997 Legacy GT Sedan 5MT in Rio Red.

It's so clean. It's the cleanest car I've ever had! Look at those arches!

Underneath is immaculate, at least for New England. I bought it in Mass with 187k for only $500! It needs a windshield, tires, and head gaskets to be daily-able.
BUT! It comes on adjustable coilovers and has the perfect gearset IMHO.

I'm just so excited about this car! You know I'll be turboing it. The engines formerly meant for my '95 coupe will now go into this car, and the '95 will again have H6 goodness! :naughty: This time I'm definitely gonna turbo that H6!

Anyway, gotta thin the heard so if none of my friends want the bugeye, it'll be on here cheap. Sure it needs work, but it runs great and doesn't even leak.

Plans for the LGT include a new windshield, tires, GOLD rims, lower, and boost. I can't wait!
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #37 (Edited)
I set the lofty goals of finishing both my Legacy and my Impreza by the end of this weekend. Well, maybe not finished, but running and driving under their own power. For the Legacy that means:

Remove EJ25D w/ bad head gaskets ✓
Modify crossmember/seal against rust
Clean: everything
Relocate: CC module, CC actuator, main harness connection, ignitor module, and much more
Heat wrap/shield: wiring harnesses, PS lines, AC lines, AC drier/evaporator(?)
Replace master cylinder with Impreza unit, to clear TMIC
Probly forgetting some things. I plan on running it with the waste gate actuator disconnected so it won't build boost until after I get an inspection sticker, then I can screw with electronics.

Engine out, and a dirty, dirty engine bay.



Hopefully I'll get the 'clearancing' done tonight and the new motor in. I've got a decent drive to make to pick up some goodies after work, so it may not get done. I'll get some pics of the goods.
 

·
Registered
1995 EZ30 Coupe
Joined
·
493 Posts
Discussion Starter #39 (Edited)
Before:


After:


Comparo:

'97 LGT to the left, circa '99 Impreza on the right.
Surely that's not just another bleed point on the Legacy line, can anybody shed some light?

That should be enough room for the top mount. Hopefully.
 
21 - 40 of 73 Posts
Top