Subaru Impreza GC8 & RS Forum & Community banner
1 - 10 of 10 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
My buddy has problems.

He is getting a slight misfiring of pistons and lower idel.

He had gutted cats but got that fixed, he lives in Washington State. He checked all the wiring and was wondering if it was the tps sensors or other sensors around the engine bay?

He also fixed the O2 sensors and got new plug wires at the dealer. His CEL light came on the dealer fixed his Ecm and the cats; that got rid of the CEL warrning. Coil is good, dealer said, so are plugs & wires. The Idel is lower and there is a slight misfire still happening.

Help What is wrong???
:run:
 

·
Registered
Joined
·
599 Posts
Have him check his IAC (Idle Air Controller), its an expensive little bastard to replace ($350ish). Mine is dying and from what I can understand from your description, mine does the same thing. Is his car throwing any CEL's? If so tell him to get get it Code scanned and that should tell him what sensor is on its way out....
 

·
4 please, to go.
Ver 7 STi GC, elderly L
Joined
·
3,623 Posts
Hey, i did a search for misfiring and came up with this thread. My car is almost exactly the same as the one described above, 47k miles, 2001 sedan. I had to jump my car the other night because of the cold and immediately after starting i throw a CEL. So, i was told by someone that it might be a over-voltage reading from the jump. But when i had the auto parts store check it out today, i got cylinder's 1 and 2 misfiring. What gives? Is the problem related? I have brand new plug wires, other than that i don't know. Could my timing have been thrown off by the jump? If so, how the hell do i fix the timing. Any help would be hot. Thanks, josh.
 

·
Registered
1997 Brighton 2.5
Joined
·
1,213 Posts
I'd have them reset your ECU, and wait to see if it comes back. I bet it doesn't. Just sounds strange.

Wait a minute, aren't you still under warranty? Use it.
 
1 - 10 of 10 Posts
Top