Subaru Impreza GC8 & RS Forum & Community banner

201 - 214 of 214 Posts

·
Registered
1998 GF8, 2003 BH9
Joined
·
157 Posts
If you can find me a set, would buy! I want to get an Outback front bumper for it too, but that I can find locally.
Yeah easy. Next time I'm at the wreckers I can find out how much they'll be. I'd guess 60-90 AUD (40-60 USD).

You wouldn't want an AUDM outback bumper anyway as we have the flaring on the fenders and that continues on the bumpers
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #205 (Edited)
Yeah easy. Next time I'm at the wreckers I can find out how much they'll be. I'd guess 60-90 AUD (40-60 USD).
Sounds like a fair price, lemme know when you find a clean set! I know shipping will be the worst part, haha

Put an air filter and bov on the impreza. It was actually kind of fun to drive it without gauges, nothing to stress about... just drive! But getting it warm did prove it has excessive blowby, none of the cylinders sound weak, so not sure if ringlands or something else..
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #206
I haven't done much with the car other than drive it, the emanage comes out every time as my antitheft for now, even if it's just a quick run in to the store, they can tow it away but it won't drive!


I'm totally taken aback by how good it runs and drives not having the greddy 3 bar map and AFR signals piped in to it. I have no idea what the fuel trims and such are but it runs, drives, and boosts great! I've probably put 1.5 tanks of gas through it and still has not shown a CEL. It would be clockwork prior to the theft, on the second drive cycle the P0136 for my rear O2 circuit would come up. I remember taking out the spacer to see if that was the issue before it was stolen, which it wasn't, and the car has no catalysts so at the very least I should be getting a P0420.


So right now the car is boosted with the bare minimum, no timing adjustment on wastegate pressure and it's happy as a clam.
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #209
HAH. No, not in the slightest. The thief allowed me to see the car in another way by removing the AFR and MAP sensor inputs to the emanage. Admittedly I have plugged the greddy map in to the emanage and the car basically refuses to run when I do, soon as I unplug the greddy map the car evens out and is happy. I have all the boost cells at 0 in the emanage so extra fueling in boost is being done by the factory ECM and the 1:1 FPR. I may get motivated enough to warm it up and do a compression test on it, I've literally done nothing to it since it was stolen, haha.

The Legacy has had two alternators, the first replacement had a bad bearing, rear pads and rotors, and a power steering rack assembly is on the way, LOL.
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #211
The greddy map sensor i had bought was used, so it was probably bad the whole time and why i couldn't get it tuned well enough and almost always ended up with cells hitting 100. I'm going to order a vagcom cable today so I can monitor fuel trims and see what it's actually up to. It did finally trigger a CEL, P1112, which is related to the MAP. May not have the map clamp at the right voltage.
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #212
Installed the new rear O2 sensor, with no change. Went through the diagnostics procedure for P0136 in the service manual. Calls for less than 3 ohms resistance between ECM and O2 harness connector. I read 0.6 ohms. Then calls for .2V with key on at the O2 harness connector and I've got a big ole ZERO. I'll have the new front O2 sensor installed soon and see if that makes a difference.

I absolutely despise electrical problems. Time to set the car on fire!
So I had found in the FSM where the .2V was supposed to come from out of the ECM, and there was no wire there... wtf? Took a little bit of digging, but I found the FSM correction page where they had mislabeled the connectors. :projectsti.com:

Got the new front sensor's wiring extended and installed. Got to probing wires to diagnose my P0136 code and pretty sure we've deduced a bad ECM. No voltage coming out of the ECM for the rear O2. Perfect opportunity to explore a WRX ecu swap this summer.
I was chasing this damn problem for a year... loose auxiliary connection at the battery. I hate myself so much.
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Discussion Starter #214
Honestly I probably shouldn't be allowed near a toolbox. But oh well!

I don't have much of an update for the car, just been driving it since it's been recovered. blowby is getting kind of bad but it still fires up strong, could be from lack of oxygen sensors though...who knows.... should get a catch can maybe.. car hasn't "felt" right since being recovered, finally figured out the front struts are goobered, I replaced many parts in the front end trying to chase the shimmy down, but turns out the strut piston has play in the strut body allowing some sick active camber, especially fun on roads with deep divets. I did find a couple weeks ago it seemed as though the thieves came back for the car, floorboard was freshly wet and I hadn't been in it in over 12 hours, but without the emanage it wouldn't start so I got to keep it this time. So that was the final straw, I had a Viper 2-way installed. I didn't think I'd like remote start as much as I do, but holy shit, if you don't have it, get it!

LGT got a new steering rack, new tre's, ball joints, and I ordered hub centric rings for the konigs it came with. 208k and fully expect it to make it another 100k at least.
 
201 - 214 of 214 Posts
Top