Subaru Impreza GC8 & RS Forum & Community banner
61 - 72 of 72 Posts

·
Registered
Joined
·
147 Posts
Pulled the ej18 out of the car, and have the ej22t on a stand next to it. The "just swap the intake over" is a lie lol

I'm currently swapping all of the sensors and such between the two engines, but am currently trying to figure out what to do with the wiring. The ej18 intake harness has the plugs right next to the stock turbo location. It seems to me having your engine wiring next to the hotside of the turbo is no bueno, so I'm trying to figure out the best way to reroute the wiring away from the little whirly boy/fire hazard.
Have you made any progress? Nice looking coupe!
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #62 ·
Thanks dude!
Update: The engine is in the car, bell housing bolted up, starter on, intake on. I'm in the process of sorting out all of the small wiring, coolant/vacuum lines. The ej22t was out of a 1992 legacy ss w/ an auto trans, and was pulled by someone about a decade ago. It sat in the corner of his garage for a while, and it's sat in my garage for about a year, so I'm going to throw some oil in it with some Marvel Mystery Oil, and see if I can turn it over hopefully in the next couple weeks. I'm missing out on local autox events this year, and it's bugging me. lol

The project has been held up since I just moved, and I keep getting covid. lol So hopefully I can post a picture of it after it's moved under it's new power here soon
 

·
Registered
Joined
·
108 Posts
Thanks dude!
Update: The engine is in the car, bell housing bolted up, starter on, intake on. I'm in the process of sorting out all of the small wiring, coolant/vacuum lines. The ej22t was out of a 1992 legacy ss w/ an auto trans, and was pulled by someone about a decade ago. It sat in the corner of his garage for a while, and it's sat in my garage for about a year, so I'm going to throw some oil in it with some Marvel Mystery Oil, and see if I can turn it over hopefully in the next couple weeks. I'm missing out on local autox events this year, and it's bugging me. lol

The project has been held up since I just moved, and I keep getting covid. lol So hopefully I can post a picture of it after it's moved under it's new power here soon
Let me know if you need any parts off of a stock 2.2T, I have 3 complete motors.
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #64 ·
Let me know if you need any parts off of a stock 2.2T, I have 3 complete motors.
Do you happen to have any complete 90° rubber turbo inlets? Mine has one of the vacuum ports broken off, and I'm trying to figure out how to reattach it in the best/most efficient way
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #67 ·
Threw some oil in it last night and tried to start it for the first time; it tries to start, but won't idle. So I'm having a fuel or vacuum issue. Going to keep working at it
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #68 ·
Aaaaand I spent actual money on new parts instead of something from the junkyard. I'm waiting on a manual boost controller and an air/oil separator. When those things get here, the engine will get all new vacuum lines to pretty much every line, so we shall see.
Buying new parts was kind of amusing. I'm so used to buying junkyard parts, that when I bought brand new parts, my credit card company called me to confirm it wasn't fraud. So that's pretty damn funny. lol
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #71 ·
The parts got here today, which means I have quite a fair bit of work cut out for me tomorrow. Hopefully I can get it started/running right this weekend

Material property Office supplies Rectangle Font Writing implement
 

·
Registered
1995 1.8L Impreza Coupe
Joined
·
223 Posts
Discussion Starter · #72 ·
Good news. The car cranked and ran briefly (didn't connect the cooling stuff, so didn't run long), so all seems well enough to put everything together and start diagnosing small issues as they happen. Still doesn't idle, I think it has to relearn a fuel map. But with throttle input it sounded good (even with no exhaust)

Bad news. The IAG air / oil separator does not fit the GC bodystyle well, and would take a lot of moving things around and modifying things to make it work. I'm probably going to put it on my forester instead, and get the Grimmspeed AOS for the GC; it's just easier that way. I'll edit this post in a bit with the amusing rats nest of hoses I ramshackled together to test start the car though.
 
61 - 72 of 72 Posts
Top