Subaru Impreza GC8 & RS Forum & Community banner
1 - 20 of 22 Posts

·
Registered
1999 RS Coupe
Joined
·
289 Posts
Discussion Starter · #1 ·
my rs seems to be losing power at 3700 rpm but then when it gets to about 4200 rpm it kicks back in and it more torque....I just bought this car anyone no what this possisbly could be
 

·
Registered
1999 Subaru Impreza L Coupe
Joined
·
281 Posts
Are there any mods done to the car? Exhaust, intake, cams, light weight flywheel/pulleys? Sounds like the computer isn't agreeing with something.

Also does this only occur at wide open throttle or gentle-intermediate acceleration?

Greg
 

·
Registered
2005 Subaru Impreza RS 5MT
Joined
·
2,827 Posts
Do all the maintenance (don't forget the PCV valve), run some Sea Foam through there, and reset your ECU. You may just want to reset your ECU first only to see if anything changes. If that doesn't fix it, then it's something more mechanical to be diagnosed.
 

·
Registered
2.5RS Rally Car
Joined
·
2,066 Posts
Does it loose a lot of power? Or just a tad? If it just feels a little bit sliggish, it may be the knock sensor. Any CELs?
 

·
13 Years of RS
2005 Toyota Corolla :(
Joined
·
5,532 Posts
There's a little flat spot in the powerband right there, I'm pretty sure that's all you're feeling. I's common on these cars.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
Mine had a "flat spot" when I was running the 95 1.8 ecu on the 2.5 dohc. But now with the jdm legacy 2.5 ecu, there are no "flat spots". Silky smooth. Maybe its something with emissions?
 

·
Anti-Nonsense
2004 2.5 RS, 1973 L48 Corvette
Joined
·
438 Posts
Doesn't the ECU switch from closed loop to open loop right around that RPM? Could that be it? I always thought it was around 4000 RPM, and that characteristic dip in power on the EJ25 was cause of it?
 

·
Registered
2017 STi
Joined
·
9,572 Posts
02 sensor. Also try changing your sparkplugs and wires. My 02 sensor was doing this and I had no CEL. It was sluggish all the way up to 4k rpms and then the power kicked in around 4,000rpms
 

·
Registered
2000 Subaru Impreza 2.5RS BRP
Joined
·
172 Posts
I was told from a Subie builder near me that replacing the stock fuel pump with a walbro 255 will stop that flat spot. Haven't had the time or energy to do it, but an upgrade is always fun.
 

·
Registered
2017 STi
Joined
·
9,572 Posts
I was told from a Subie builder near me that replacing the stock fuel pump with a walbro 255 will stop that flat spot. Haven't had the time or energy to do it, but an upgrade is always fun.
Bump ^^^^^^^^ can anyone confirm this?
 

·
Premium Member
00 V7 RSTi racingbrake4pots
Joined
·
1,023 Posts
that's not something I've ever read on here before! If your hesitation gets worse I bet it's your O2 sensor.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
I was told from a Subie builder near me that replacing the stock fuel pump with a walbro 255 will stop that flat spot. Haven't had the time or energy to do it, but an upgrade is always fun.
This will not work. The stock pump has more than enough fuel and its a constant speed pump with pressure regulated by your fuel pressure regulator under the hood. It doesn't suddenly decide to produce more fuel after 3700 rpms.
 

·
Registered
95 GC 371hp/355tq ej25 1.5xtr
Joined
·
4,494 Posts
i say the plugs. when i changed the plus on my legacy gt, the gap was pretty big and the car not only sounded. but ran ALOT better
 

·
Registered
2002 Subaru Impreza OBS
Joined
·
821 Posts
yeah just to clarify, i have a bad o2 sensor and my hesitation is fairly noticeable. Once i get some time its time to change that and probably plugs as well.
 

·
Registered
95 GC 371hp/355tq ej25 1.5xtr
Joined
·
4,494 Posts
yeah just to clarify, i have a bad o2 sensor and my hesitation is fairly noticeable. Once i get some time its time to change that and probably plugs as well.
whats your MPG with the bad O2? it should be pretty shitty... IIRC
 
1 - 20 of 22 Posts
Top