Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

·
Premium Member
2015 WRX STI WRB
Joined
·
8,417 Posts
Discussion Starter · #1 ·
so i have these really nice SARD gages in the car and i want to replace the sensors for them.

ofcourse since they are nice, they are also super rare and i haven't been able to find replacement sensors for them.

can someone point me in the right direction? as far as i know DEFI sensors only work with DEFI gages which is too bad since the sensors are readily avaliable.

thoughts suggestions?
 

·
Premium Member
2015 WRX STI WRB
Joined
·
8,417 Posts
Discussion Starter · #2 ·
SUPER MAD JDM TYTE YO!

SARD 52mm gauges.

when i had the swap running a few months ago the gauges got power but i didn't finish setting them up properly.








 

·
Registered
99 GM8
Joined
·
5,801 Posts
My best guess is find a different mfgers gauge that is calibrated for the same telemetry parameters and go from there. If i'm not mistaken an electric signal is an electric signal, so if say greddy's oil psi gauge setup is calibrated for the same range on your SARD's it should.....work
 

·
Premium Member
2015 WRX STI WRB
Joined
·
8,417 Posts
Discussion Starter · #5 ·
ya i was looking at rhdjapan it looks like they have some replacement sensors but i'm not exaclty sure if those will work. i kinda wanted to keep these gages.

the boost gage doesnt really need a sensor right?
 

·
Premium Member
97 L, 13 WRX
Joined
·
1,537 Posts
It looks like the boost gauge has a vacuum line next to it. It shouldn't need a sensor if there is a vacuum port on it. It will most likely just need switched power to light it up at night.

Edit: I think the vacuum line is next to the temp sensor, but I'm sure it came with the boost gauge, right?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top