Subaru Impreza GC8 & RS Forum & Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
Well, after having the everloving crap scared out of me by the mushy pedal to the floor ABS system in my WRX, I decided to pull the ABS fuse. For the last week or so.... I haven't had a problem. Tonight... it rained... so I decided to test.

On freshly wet pavement... oils washed to the top by about a 45 minute light rain.... doing 20mph down my street, I slammed on brakes.

NOTHING. Slowed to a stop like I should. I sped up and did it again... and again... nothing. No lockup, complete control. What the hell?

I turn around, and speed up some more... this time from 35mph. ONCE AGAIN... no lockup. I was hitting the brakes HARD too.

I, for one, am convinced that the ABS system is a complete piece of crap. I know some of you have said that the 2.5RS doesn't do it.... and I know that I can't get my friend's 2.5RS to create that ABS CS* light. Then again, you've also said that automatics don't have a problem... and his is an automatic.

You guys draw your own conclusions... but I'm now glad that I got rid of that fuse!

*CS = Check Shorts
 

·
Registered
Joined
·
796 Posts
The ABS on my car works great, and I have an RS 5 speed.

Of course, I think that it may have something to do with the extra 300 lbs and Subaru probably using the same computer to control the ABS system.
 

·
Registered
05 STi White + 99 RS White
Joined
·
1,828 Posts
The RS doesn't have the best ABS. It hates uneaven street and bumps. If you are slowly stopping, and hit either, the ABS kicks in when it shouldn't and you get this nasty out of control feeling for 1 or 2 seconds. I don't like that feeling...:(
 

·
Registered
Joined
·
14 Posts
If your car will not lock up with the ABS disabled, there is a problem with your brakes. Take it to the dealer! At the very least they need to be bled.
 
1 - 4 of 4 Posts
Top