Subaru Impreza GC8 & RS Forum & Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I need some help on determning what exactly went wrong with my car last night, maybe it happened to someone else who might own a 1.8l L sedan.

CAR: 1994 1.8l Sedan, just turned 100,000 with all major tune up's. I bought the car with 97,000.

SCENARIO:
I was driving down this road by my house, and began to slow down for a car making a right turn. As I was slowing i depressed the clutch, and applied the brake. All of the sudden, my battery light came on along with my e-brake light. I began to hear a small fizzling sound from the engine bay, and I continued to a spot where i could pull off. As i was about to pull off, the battery light, and the brake light in my dash went off and things were fine. I came to the next stop, and was turning left when my powersteering went out, and I continued to hear a small fizzle-type of sound from under the hood. I turned around not far from my house, and drove back, when it sounded as if there was a belt slipping (loud squealing).

I checked the powersteering fluid and it was low/non-existent (the one fluid i forgot to check when i bought the car 4 mo's ago). I filled it up, and now all that seems to be the problem is the loud squealing belt.

I was thinking, could be the powersteering motor, alternator, timing belts, power steering belt? Any info would be much appreciated!

Thanks,
Peace.
Garth
 

·
Premium Member
Two Mini Coopers!
Joined
·
10,629 Posts
Loud squeeling is typically a loose belt. You should be able to adjust the alternator belt (which connects to the P/S pump as well if I recall correctly) and that would be it.

The fizzling noise... probably the lack of fluid in the P/S pump.
 

·
Registered
Joined
·
1,799 Posts
loud squealing in my 1.8 rally car was ALWAYS the PS Pump...
not the belts... the bump ran out of fluid... and squealed like ya wouldnt believe..... i had to drive it that way until we could legally service it...

3 ps pumps later... i knew that sound very well!
the 3rd pump has never leaked or had an issue.... :)

if you were totally out of fluid, my guess is ps pump is toast

cheers
Jamie
www.subiegalracing.com
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
subie gal-

thats what i told my mechanic, but he just replaced a belt, seems to beworking fine so far. i guess ill end up finding out later on. i told him about your suggestion to. i dunno, we'll see what happens. by the way, how hard would it be to swap the pump for a new pump? i dont really have any tools here in bellingham, but i know some people here that do, and i was thinking i might end up changing it out if its easy.

Thanks a ton!

peace.

garth.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
"IMMMmMMMMMMMM BAAAAAAAACK!!"
--Power Steering Pump.

yea, im just gonna swap it, i need to swap the FRONT CRANK GASKET/SEAL?? not to sure exaclty, but its leakin oil like mad right onto the exhaust manifold. any advice Jamie??

Thanks
Garth.
 

·
the hard way
1972 240Z
Joined
·
10,462 Posts
might as well put it up in this old thread since im havin the same issue (i think)

i just changed my PS/alt belt a couple days ago and it is still squealing. i tightened it up to what i would consider the brink of too tight and still squeals (i loosened it back up thereafter). so im wondering if its my PS pump.. the squealing noise is only made when the steering wheel is to the left or straight (silent as a cow when to the right) :confused: does this make sense? should i not worry about it and assume its rust/dirt from the old belt? is this the purpose of belt conditioner?
the power steering fluid is not, and i dont believe has ever been, low..?

please help. i feel like im drivin a POS. thank you very much in advance
 
1 - 8 of 8 Posts
Top