Subaru Impreza GC8 & RS Forum & Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hope all is well !

I have a 98 Sti Sedan
I recently had a dead battery
I charged it, and it worked for one day,
The day after, I had no power at all in the car
Only the hazards will allow the turn signals to stay on, is it a blown fuse? And if so ? Which fuse? I’ve check by eye and I wasn’t able to find any thing 🙃
 

·
Registered
Joined
·
173 Posts
IT could be the relay for the turn signals. I believe the turn signals and hazard lights are on separate circuits IIRC. If you charge the battery and it's dead again the next day it's either a bad battery or bad alternator or there is an electrical draw in the system due to a short of some type.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I’m aware that there may be a short, I’m hoping to find out which fuse being that it’s the Japanese model
 

·
Registered
'96 OBS
Joined
·
329 Posts
wait, so turning on the hazards causes the turn signals to all just stay on (without blinking)? Or the turn signals don't work unless the hazard switch is on? And is that the only electrical device that powers on in the car at all?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Correct, nothing else on the car has power, only the hazards lights which stay illuminated when turned on , and the emergency park switch over the steering wheel is off as well
 

·
Registered
'96 OBS
Joined
·
329 Posts
k, couple thoughts: check your dome light as well. The dome light, hazards and parking lights don't run from the main relay. They run directly off the battery if I recall correctly. The main relay should be triggered by the key being in the on position.

I'd also check your turn signal flasher module. Maybe just yank it out and see if eliminates the battery drain. In addition to that, I'd check the engine-bay fuses and relays, especially the main relay.
 
1 - 6 of 6 Posts
Top