Subaru Impreza GC8 & RS Forum & Community banner
1 - 18 of 18 Posts

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #1 ·
Hey guys my car has been actin up lately... when i hit the gas sometimes it sputters and then kicks back on. I ran the scanner and it came up with a po304 which is a cylinder 4 misfire. I know it could be multiple things but anyone know some likely bets before I go testing stuff or blowing money. Thanks in advance.
 

·
Registered
2017 STi
Joined
·
9,572 Posts
Does it feel like it is hesitating and then your power kicks in?
 

·
Registered
2006 Impreza WRX Limited
Joined
·
2,603 Posts
My bet would be front 02 sensor. Its $78 shipped from subarupartsforyou.com and I got mine really quickly.
 

·
Registered
2017 STi
Joined
·
9,572 Posts
^^^^^^beat me to it.
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #6 ·
I was under the impression that the front O2 sensor threw a seperate code. Or wouldnt it at least cause multiple cylinder misfires if its causing one cylinder to misfire.
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #7 ·
Does it feel like it is hesitating and then your power kicks in?
yeah it kinda sputters like its tryin then kicks in.....and for the above post my front 02 was replaced not long ago and i remember when it went bad and dont remember the symptoms being the same
 

·
wood grain grippin'
v2 STi wagon
Joined
·
3,399 Posts
Not an O2 sensor.

P0304 meanz "Misfire on Cylinder 4 Detected, Yo"

So here's what it could be:
-spark plug #4
-injector #4
-spark plug wire #4
-coilpack

It could also be something like a bent valve or some loss of compression... but if something is only happening in cyl #4, then I'll bet that it's something like a plug, wire, or injector.

Brett
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #9 ·
Not an O2 sensor.

P0304 meanz "Misfire on Cylinder 4 Detected, Yo"

So here's what it could be:
-spark plug #4
-injector #4
-spark plug wire #4
-coilpack

It could also be something like a bent valve or some loss of compression... but if something is only happening in cyl #4, then I'll bet that it's something like a plug, wire, or injector.

Brett
yea thats what i thought to.....i just replaced the plugs actually it was due anyways ill update if that does it or not if not time to bust out the multimeter on the coil bitch haha
 

·
Registered
2017 STi
Joined
·
9,572 Posts
yeah it kinda sputters like its tryin then kicks in.....and for the above post my front 02 was replaced not long ago and i remember when it went bad and dont remember the symptoms being the same
Mine does that sometimes also and I still can't figure out what the hell it is. I don't throw any CEL's or anything but sometimes it just does it. Although I will say that after I installed the grounding kit from PF it accelerates smoothly all the way up to redline. It only happens once in a while now. I also changed my sparkplugs and o2 sensors and it still does iton occasion. So I'm going to go with bl_easy and say injector #4 or the coil pack. I really don't a dirty think a PCV valve would cause it but who knows. I'm still a noob.

EDITED
 

·
wood grain grippin'
v2 STi wagon
Joined
·
3,399 Posts
One thing to try is getting some Injector cleaner additive that you dump in your gas. If it's a sticky injector, this could help loosen it up. It's definitely worth a shot for about eight bucks.

Mine does that sometimes also and I still can't figure out what the hell it is. I don't throw any CEL's or anything but sometimes it just does it. Although I will say that after I installed the grounding kit from PF it accelerates smoothly all the way up to redline. It only happens once in a while now. I also changed my sparkplugs and o2 sensors and it still does iton occasion. So I'm going to go with bl_easy and say injector #4 or the coil pack. I really don't a dirty PCV valve would cause but who knows.
I'm not talking about a PCV valve. Again, that is attached to the intake manifold, and would probably affect all cylinders, right? I was talking about the valves in the cylinder head. :) Specifically, the ones for a certain cylinder...
 

·
Registered
2017 STi
Joined
·
9,572 Posts
One thing to try is getting some Injector cleaner additive that you dump in your gas. If it's a sticky injector, this could help loosen it up. It's definitely worth a shot for about eight bucks.



I'm not talking about a PCV valve. Again, that is attached to the intake manifold, and would probably affect all cylinders, right? I was talking about the valves in the cylinder head. :) Specifically, the ones for a certain cylinder...
I know I'm just throwing shit out there. Still learning over here bud. :) i said I agreed with you on. And that I changed my sparkplugs and it still occured sometimes.
-spark plug #4
-injector #4 <--------------
-spark plug wire #4
-coilpack<-------------------
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #13 ·
Well luckily it was just a fouled out plug.....the first and only thing I was gonna replace before testing to see exactly what it was haha. Its runnin perfectly fine now. Thanks for the fast responses anyways guys.
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #15 ·
Mine does that sometimes also and I still can't figure out what the hell it is. I don't throw any CEL's or anything but sometimes it just does it. Although I will say that after I installed the grounding kit from PF it accelerates smoothly all the way up to redline. It only happens once in a while now. I also changed my sparkplugs and o2 sensors and it still does iton occasion. So I'm going to go with bl_easy and say injector #4 or the coil pack. I really don't a dirty think a PCV valve would cause it but who knows. I'm still a noob.

EDITED
As far as your problem goes....sounds like things could just be gummed up a bit if its only doin it once in awhile and youve already replaced things. Im sure youve tried fuel injector cleaner but if not do that like mentioned above. You might try some Seafoam through the PCV valve and see if that smooths everything out. Theres a thread out there somewhere on it just search for Seafoam. It just cleans out carbon build up in the cylinders makes it idle a bit smoother etc....
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #16 ·
Is there oil on your spark plug boot?
Not on the boot no... there was some on the plugs but it was old and caked on because I recently replaced my valve cover gaskets which is where im assuming you were goin with what you said above.
 

·
Registered
2017 STi
Joined
·
9,572 Posts
As far as your problem goes....sounds like things could just be gummed up a bit if its only doin it once in awhile and youve already replaced things. Im sure youve tried fuel injector cleaner but if not do that like mentioned above. You might try some Seafoam through the PCV valve and see if that smooths everything out. Theres a thread out there somewhere on it just search for Seafoam. It just cleans out carbon build up in the cylinders makes it idle a bit smoother etc....
Yeah I was thinking about seafoaming it. After everything I've tried I don't think it would hurt. It's weird because sometimes it will hesitate and about 2 weeks ago I was cruising in fifth gear on the parkway and I couldn't go above 3,600rpms. hasn't happened since then but I don't know. I think I am going to try the seafoam
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Discussion Starter · #18 ·
Yeah I was thinking about seafoaming it. After everything I've tried I don't think it would hurt. It's weird because sometimes it will hesitate and about 2 weeks ago I was cruising in fifth gear on the parkway and I couldn't go above 3,600rpms. hasn't happened since then but I don't know. I think I am going to try the seafoam
Huh thats weird. Ya got me on that one then. That sounds electrical rather than mechanical but who knows its hard to say without experiencing the problem. Good luck hope you figure it out. Seafoam cant hurt at least
 
1 - 18 of 18 Posts
Top