Subaru Impreza GC8 & RS Forum & Community banner
1 - 14 of 14 Posts

· Registered
2000 WRX STI Type-RA Limited
Joined
·
778 Posts
Discussion Starter · #1 ·
Yesterday my car started making weird noises that sounded like bearings going bad so I go there is my wheel bearing going bad. So I got my engine off and roll down a hill and it continues.so i go its definitely my wheel bearing. But when I am stopped with my engine running it continues rattling/grinding. BTW my check engine light is on but I figured it was because of my new cat. Today when I moved my car It started running really rough the second I started it so I'm like WTF so I proceed to rev it up once and then my exhaust started smoking so i kill it it and my exhaust is still smoking which I can tell is oil burning. So now i'm super pissed cause I just got this car a few months ago and I am already having problems. I'm pretty sure it is not the head gaskets hence the noises and my buddy thinks it might be the bottom end. The car is right at 150,000 miles and ran fine until now I really just want to get a new low miles N/A engine from East Coast Swappers and not worry about future engine problems. Unfortunately, I don't have the money because I just spent $700 on suspension and am out of work due to a broken collar bone. So right now I am heart broken because I love my car and it's all I got. Anyways what could it be? I am scared to start it and move it for the fear of causing more damage. Should I take it on my friends trailer to auto zone to get the code read?
Any help/Info would be greatly appreciated.
 

· Registered
1998 Subaru Impreza RS - RBP
Joined
·
1,762 Posts
Yes, either take it to get the code read, or get the $30 scanner from autozone and scan it yourself and post the code you get on here.

You may have had rod knock... maybe now you busted a piston ring.
I don't really know what it could be man. Sorry!

Get the code and let us know!
 

· Premium Member
2002 2.5 RS-T
Joined
·
3,814 Posts
strange.....when u rolled down the hill were u in gear?? or coasting with the clutch in?

u should do compression and leakdown test...post up results and we can go from there....

also for the hell of it check for oil in coolant and coolant in oil....

if compression and leakdown are ok go ahead and get a video of the sound....post it up

if its problem with the block u can get an rs shortblock for cheap and replace it...same deal with the heads.....

ps to scan the codes....go to walmart, by a code reader...scan codes....then return the code reader....walmart return policy FTW....and honestly...who feels bad about scamming walmart? lol
 

· Premium Member
96 GF4 " Bruiser"
Joined
·
5,136 Posts
Start with the code. At auto zone they have them for rent so you dont have to pay anything in the end. Just leave a deposit.

OK the knock, you said that when engine off rolling it was making the noise and also sitting still idling it was making the noise.

Best describe the noise. Does it keep rhythm with the motor ( ie it gets louder or faster with RPMS) or rhythm with wheel speed? Does it sound light? Heavy?

The smoke your seeing is probably from the fresh cat. they tend to smoke a bit from being new. No need to worry unless there is a smoke storm. Check what your oil looks like and see if there is ANYTHING in there. then add a little bit of lucas or your fav brand of oil stabilizer. it would help with rod bearing chatter if they are worn out.

Let us know and i hope that we can help
 

· Premium Member
2002 2.5 RS-T
Joined
·
3,814 Posts
oh and dont fear....when i had my bad emanage ultimate the car ran very rough and PUMPED smoke as well as made horrible noises.........try not to use your jump to conclusions mat just yet :)
 

· Premium Member
2002 2.5 RS-T
Joined
·
3,814 Posts
That kicked my ass!!! :blol:

Thanks for making my day man!

lol thats how i roll.....

this also works for air conditioners in the summertime....30 day policy FTW! take it back, turn around and buy it again for a month....no questions asked.....you'll never lie awake sweating at night again...no matter how broke u are!...
 

· Registered
1998 Subaru Impreza RS - RBP
Joined
·
1,762 Posts
lol thats how i roll.....

this also works for air conditioners in the summertime....30 day policy FTW! take it back, turn around and buy it again for a month....no questions asked.....you'll never lie awake sweating at night again...no matter how broke u are!...
You have just opened a whole new world to me! Thanks!
*starts thinking of random things he wants...*

Okay, back on topic!
 

· Registered
2000 WRX STI Type-RA Limited
Joined
·
778 Posts
Discussion Starter · #9 ·
Yes it was in neutral. No I can't record it. I don't think it is my cat smoking because It wasn't smoking on the two previous days. Plus it smelled like burning oil. As for the noise.. It went away now but i didn't move very far. Also it didn't keep rhythm with anything it would go away for a few seconds then come right back. Thanks for the Wal-mart tip. I'll have the code tomorrow.
 

· Premium Member
2002 2.5 RS-T
Joined
·
3,814 Posts
Yes it was in neutral. No I can't record it. I don't think it is my cat smoking because It wasn't smoking on the two previous days. Plus it smelled like burning oil. As for the noise.. It went away now but i didn't move very far. Also it didn't keep rhythm with anything it would go away for a few seconds then come right back. Thanks for the Wal-mart tip. I'll have the code tomorrow.

hmmm strange....good news though!....get in the engine bay and make sure nothing is loose!
 

· Registered
2000 WRX STI Type-RA Limited
Joined
·
778 Posts
Discussion Starter · #14 · (Edited)
Turns out that I am just a dumbass. One of my spark plug wires was loose and and was causing it to miss a cylinder. So I pushed it back on all of the way and it runs fine now. As for the weird noise, it probably was one of the headers heat shields. The check engine light also went out. I have never been so happy to do something so stupid.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top