Subaru Impreza GC8 & RS Forum & Community banner
1 - 19 of 19 Posts

·
Premium Member
2005 rs silver
Joined
·
1,313 Posts
Discussion Starter · #1 ·
P0032 code is on my 2005 rs ... i changed both mother fuckin sensors just incase and that lil ma fuckin light and cruise light is still on and i wanna light my car on fire and cook it like a marshmellow... if any one has ne ideas or ne input id really appriciate it... and no fuckin flamin about my grammer :blowingup
 

·
Premium Member
98 OBS, Black/Grey
Joined
·
2,724 Posts
Did you replace the sensors with oem sensors or aftermarket or aftermarket generic (where you have to splice your plug on)?
 

·
Premium Member
98 OBS, Black/Grey
Joined
·
2,724 Posts
you might of spliced the wrong wires... double check everything.
 

·
Premium Member
2005 rs silver
Joined
·
1,313 Posts
Discussion Starter · #7 ·
you might of spliced the wrong wires... double check everything.
i did 9 million times i have a assiates degree in electrical so i strive for perfection with wiring so i still dont get it
 

·
Registered
'00 2.5RS - Coupe - SRP
Joined
·
26 Posts
i would just replace a bad O2 sensor with a bosch sensor. bosch makes them for Subaru anyways. also couldnt splicing the sensor in potentially create a variance in resistance? i thought O2 sensors compare voltage to each other, and if one has a different resistance than the OBDII may throw a code.
 

·
Premium Member
2005 rs silver
Joined
·
1,313 Posts
Discussion Starter · #12 ·
the splice in o2 sensors come with connectors to cause the least amount of resistance so there isnt an issue... i redid all my splices and that cunt is still on
 

·
Premium Member
2005 rs silver
Joined
·
1,313 Posts
Discussion Starter · #13 ·
ok bump time ... because all of u guys seem to think im retarded and cant splice i bought a brand new oem o2 sensor from subaru.... so fuckin expensive... and i still got that mother fuckin code
 

·
Registered
95 GC 371hp/355tq ej25 1.5xtr
Joined
·
4,494 Posts
ok bump time ... because all of u guys seem to think im retarded and cant splice i bought a brand new oem o2 sensor from subaru.... so fuckin expensive... and i still got that mother fuckin code
i assume you reset your ECU right? or erased the code before installing it
 

·
Registered
00' 2.5RWD / 98' L Wagon
Joined
·
4,673 Posts
Instead of roasting your car and setting it on fire like a marshmellow. You can simply send it my way, and I'll do it for you... eventually =]
 

·
Registered
00' 2.5RWD / 98' L Wagon
Joined
·
4,673 Posts
My only suggestion other than giving it to me. Would be last resort and take it into the stealership. As bad as it sounds, and as much as it's bothering you that's all I can think of.

Plus I trust your splicing capabiliteis.
 

·
Premium Member
2005 rs silver
Joined
·
1,313 Posts
Discussion Starter · #18 ·
My only suggestion other than giving it to me. Would be last resort and take it into the stealership. As bad as it sounds, and as much as it's bothering you that's all I can think of.

Plus I trust your splicing capabiliteis.

thanks for ur faith lol... my friend works at subaru so hes gettin a tech to look at it tomorrow ... fingers crossed.. and if that doesnt work... off a cliff she goes .. by accident of course
 
1 - 19 of 19 Posts
Top