Subaru Impreza GC8 & RS Forum & Community banner

1 - 7 of 7 Posts

·
GC8 FTW
Joined
·
7,470 Posts
Discussion Starter #1
i was driving up a slight hill, and decided to shift a little hard from first to second and heard a loud crack sound towards the front of the car..or front pasenger side, from what i could tell...i pulled over to take a look around didnt notice anything wrong...the next time i shifted hard from 1st to 2nd it did it again same sound....looked around nothing......its been a couple months....havent heard it since...but what could it have been?..i am stock so i dont think it would be an extreme tq issue...

-akcel:nuetron:
 

·
Premium Member
overdeveloped beater
Joined
·
8,335 Posts
motor mount?

Does it also do it when you take off from a stop? How about when cruising and letting off for a sec then followed by a stab at the gas? That would indicate a cracked motormount or pitch control rod (center and top of trans). Other than that, I can't think of anything offhand without actually being there to witness it.
 

·
GC8 FTW
Joined
·
7,470 Posts
Discussion Starter #3
nah not from launching or anything only those two times i heard it...maybe the hill and shifting hard = didnt work out too well?

-akcel
 

·
Registered
'05 LGT / '06 STi
Joined
·
539 Posts
It's possible that you 'bucked' the transmission into the tunnel. I've seen and heard it on Templar's Impreza when he launches like a maniac at autocrosses. It's has to do with the sloppy, weak-ass, no good engine and transmission mounts letting the transmission smack the underbody. Just a thought. ;)
 

·
GC8 FTW
Joined
·
7,470 Posts
Discussion Starter #5
hmmm.....well i havent heard it since...soo im assuming im alright....but hearing that crack..when it did...didnt sound too fun...it hasnt done it since..and i've dropped my clutch from 5k, only thing i heard was my rear diff make that 'thud' noise

-akcel
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
pleiades said:
It's possible that you 'bucked' the transmission into the tunnel. I've seen and heard it on Templar's Impreza when he launches like a maniac at autocrosses. It's has to do with the sloppy, weak-ass, no good engine and transmission mounts letting the transmission smack the underbody. Just a thought. ;)
and a damn fine one at that...personally the slop in subaru's mounts is unacceptable to me...that's why i am getting group n mounts shortly.
 

·
13 Years of RS
2005 Toyota Corolla :(
Joined
·
5,532 Posts
Are the factory mounts really that bad? I've never really looked at them, but I've never noticed the driveline hitting the underbody during rally-x's, either. Maybe the wheelspin helps keep the stress off the mounts, or something.
 
1 - 7 of 7 Posts
Top