Subaru Impreza GC8 & RS Forum & Community banner
1 - 8 of 8 Posts

·
Registered
1996 Impreza Brighton EJ22
Joined
·
23 Posts
Discussion Starter · #1 ·
Evenin y’all, got another issue… transmission related this time. I finally got all my shifter linkage updated/replaced and put everything back together…

I get the inside buttoned back up and start it up to back out and NOTHING. I double checked everything, made sure everything was tightened down to torque specs, if needed. Replaced the transmission fluid, tried double clutching, blipping the clutch from 1st to Reverse, 5th to reverse, still nothing. I have the Kartboy front and rear bushings(rear bushing is flat side facing down ofc), 97+stay bar as well as shift linkage bar so both of those are updated, spring is off right now to see if that made a difference or if it was a clearance issue, still nothing. Everytime I put it in Reverse, it acts like it’s in a forward gear and pulls forward.

Am I missing something? What else is there to check? I had Reverse before I replaced everything. Just can’t seem to understand why it’s in Reverse but moves forward, tried everything that I know and searched for everything.
Thanks in advance yall!
 

·
Registered
1996 Impreza Brighton EJ22
Joined
·
23 Posts
Discussion Starter · #3 ·
Whatsup Silver! Yeah man, 1st through 5th go in fine, reverse notches right in but it just won’t budge moving backwards. Double checked everything, I mean there’s only one way the stay bars and shift linkage ujoint and bar can go in correctly, right? I’ve just been flintstoning it the past few times I’ve driven it 🤣🤣
 

·
Registered
Joined
·
1,678 Posts
Wooowwwww, alldata doesn't has slim to nil for the 1996 brighton... this is the diagram for a 97 brighton, i imagine it's the same, Subaru really hasn't changed much since the the early-mid 90's. up to the 6 speed split case introduction, all the manual shifters are just like this one. If it worked before and doesn't now I would just verify the parts are installed correctly, i dunno maybe the flat side is actually supposed to go up?
 

Attachments

·
Registered
98RS, 98RS, 99RS
Joined
·
708 Posts
Did you try physically putting the car into reverse? There's a little shaft that the linkage bolts up to on the top(?) driver side(IIRC) of the actual transmission that you can pull in and out about half an inch (ish) to select gears. If that correctly puts the car into reverse then you'll have to work backwards from the case itself all the way up to the shift knob to see what's wrong.
 

·
Registered
1996 Impreza Brighton EJ22
Joined
·
23 Posts
Discussion Starter · #6 ·
Wooowwwww, alldata doesn't has slim to nil for the 1996 brighton... this is the diagram for a 97 brighton, i imagine it's the same, Subaru really hasn't changed much since the the early-mid 90's. up to the 6 speed split case introduction, all the manual shifters are just like this one. If it worked before and doesn't now I would just verify the parts are installed correctly, i dunno maybe the flat side is actually supposed to go up?
I wonder if I put the dang shift rod on backwards so it’s not letting the transmission disengage a fork to let Reverse slip in, I’ll have to check again when I get home. I’m pretty sure I checked to make sure that metal ring that holds the plastic piece under the shift boot in was correctly reinstalled.
 

·
Registered
1996 Impreza Brighton EJ22
Joined
·
23 Posts
Discussion Starter · #7 ·
Did you try physically putting the car into reverse? There's a little shaft that the linkage bolts up to on the top(?) driver side(IIRC) of the actual transmission that you can pull in and out about half an inch (ish) to select gears. If that correctly puts the car into reverse then you'll have to work backwards from the case itself all the way up to the shift knob to see what's wrong.
That’s not a bad idea, stalker. I’ll try that when I get back home after work today. Sucks when you have to work and want to be at home working on your Subie 🤬🤬 damn bills!!
 
1 - 8 of 8 Posts
Top