Subaru Impreza GC8 & RS Forum & Community banner

261 - 280 of 502 Posts

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #261
Hauled off the extras I have determined are too heavy to keep and move when I shift to a new house(when I finally find a good candidate).


As usual a 20 second task takes me weeks to start.. I have finally found the source of my squeaky clutch pedal! I'm no longer reluctant to let people ride with me hahah. Before it was a full on haunted house door.. Turns out it was squeaking on the right side of the clutch pedal bar where I had only lubed the left. No squeak, but now I have to relearn the clutch sans sound effects.
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #262
Friend helped me clean/detail yesterday, the cleanest it's likely ever been since I've owned it. Can't remember when the last time I detailed to this level. Even hit the lip with some plastic polish since it was getting pretty chalky.



Took the cam out to take a little photo, but forgot my focus ring, eye glasses or something. Every damn photo was out of focus haha..


Still had motivation so I cleaned off my wrx mats and got them in, but not sure if I'm feeling the grey mats with blue carpet. Also rear sedan mats don't cover the whole floorboard once the seat is flipped forward.


Thinking of going with a set of black all weather mats. Surprised that weathertech finally made a setup for the old coupes(link). Rear mats will need to be trimmed to fit nicely, but I like they come with score lines for trimming. Fronts look like they'll fit in nicely as well. Rubber mats are the only way to go for me, I'm a dirty dude.

Who wants to come by and install my damn afr/oil pressure gauges?? I'll pay in beer or parts!
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #264
Nah.. They went to my buddy a couple towns over that rebuilds subaru's as his main gig. He's the guy I sold my donor's shell to and has helped me with parts/info so I cut him a deal on the whole trailer load. I can't bring myself to send good parts off to the scrapers..

Driving this thing without a squeaky clutch pedal has made me very very happy
 

·
Baby❤Daddy
98L Wagon
Joined
·
27,852 Posts
its the small things. my drivers door has been making noise when opening..for like two years now. always bothered me. never di anything about it. always said, meh, i'll get it tomorrow.. etc etc etc. fixed it yesterday. it. is. SO. GLOOOOOOOOORIUSLY QUIET!!!

:lol:
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #267
Hahah yup! It's almost like we wait long enough for it to be norm so when we fix the smalls they feel like major accomplishments. When in all reality I just pushed the nozzle on the silicone spray haha


^ This makes me sad, hoping to at least band aid it before the whole spoiler goes. I have been reading up on DIY body, but really need to focus it on it for a week or two. Would like to tackle the rust and flaking clear before winter, but my cross country motorcycle trek is taking all my R&D time, money, and sleep.

Side/personal note - I finally got the green code from my work to take PTO for the coast to coast ride! Had to get the board approval for this one, rarely see a 4 week straight vaca by a Sr. Tech during the busy season. Bike is moving along well, route idea is done, 95% of my gear has been bought, and the nerves/excitement are fully setting in!


Still hard to believe my two stroke sport bikin' self owns this long hauling cruiser, but the distance definitely dictates the bike style. I've been enjoying getting it setup to suit my needs for the journey ahead. I have a project/journey thread going for the bike and ride over on another forum(Friends of the Road 2017 - Coast to Coast Attempt on a C90T). I'll try to keep most of the moto talk over there, but this trek is big for me so you'll likely get a taster here and there.

Here's a recent photo of the bike with my rotopax setup mocked up on it;
 

·
Registered
2001 SRP RS Coupe, 05 FXT
Joined
·
304 Posts
So awesome! I'm gearing up to do the Trans America Trail on my enduro bike in the next year. I'll definitely keep tabs on your adventure.
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #274
You guys convinced me! I'll pull my thread over here and keep them both post as best I can. Main reason I started it over there is I am still(and always will be) needing extra tips from some weathered road dogs. Someone out there in the subaru world probably even has a tip or trick for this young buck trying to find his way on the road?? If so, I'm all ears!



@ Bue - Yeah my west coast destination is SF. Have a lot of friends through freebord and new business friends I sold some pallets of shredped parts to. Was hoping to ride more of the CA coast, but damned if that didn't add another weeks worth of mileage. My closest stop to Torrance is around Barstow on my way from SF to the Grand Canyon's west rim. Would definitely be down to catch up!

@ Ted - Not sure if I'll ever have the urge to go v5/v6 sti wing.. I have thought about going s202 style something down the road. Really like the low wide slung wings, but stock RS still has the style I'm after.. for now at least.

@ Trev - That's rad mang!! I know some people that attempted the TAT ride on little 50cc's. None made it, clearly. Win/fail though - anyone heading for that challenge is a true rider. Some serious miles on that trek!! You have a set your departure date yet? Plan to document the ride anywhere? Always love following along with you crazy gents and gals.

Snapped this one yesterday when dropping the recycling off from work.
 

·
Registered
2001 SRP RS Coupe, 05 FXT
Joined
·
304 Posts
Plan is to start middle of September next year, before the snow hits. I'll be sure you document the journey. Maybe I'll start a thread over on ADVrider before we start. Have a blast on your journey. Would love to do that myself one of these days.
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #277
Hell yeah would be cool to link up with a couple of subaru people on the road!!

That's rad Trev, be sure to post a link here! You have a photo of your rig?

Noticed my window pads have gone bad or fully gunked up. Starting to see some scrubbage on both front windows.. Putting it on the list to do when I have cards off installing front speakers. I really should do them soon; new headunit + new rear speakers + stock front speakers = killllling me :bonk:
 

·
Registered
'00 RS / V5 STI
Joined
·
572 Posts
Let me know when you get near San Jose - I'll buy you dinner and a beer.

You are getting to do something I hope to get to over the next few years, can't wait to hear some of your stories.

-TC
 

·
Premium Member
1999 RBP RS
Joined
·
1,127 Posts
Discussion Starter #280
Will do Razor! I've put you on my planning list and will shoot you a PM with a round about date of when to expect me to take you up on that offer!!

Kept getting miffed when trying to tool on anything since my shop was still a wreck from bringing everything home. So I took some time and cleaned up the place a little. Still lots left to do.. It's approachable for now





Finally bit the bullet and started in on the gauge install. I'm terrible at wiring and also nit picky on said wiring's tidiness. So it's going to take some time to get it to a point I'm pleased with. Starting with the AFR/boost since I need it to run my logs for my tuner. Pulled it out of the pod bezel and laid it all out. Read over the instructions and a few forum posts. Unfortunately there's no good DIY on the failsafe gauge. I thought about making one, but decided against since I'm already fumbling my way around


Updated the firmware


(terrible photo is terrible)


Started the install and ran out of sunlight. Pretty damn cold out, but the sunshine kept me warm enough. Once it set I worked by headlight for a minute until I was too chilled to keep at it.

Power and ground were no problem. Attempted the dimmer using the fog light switch, but it's not liking that. Giving me a consistent dim/bright.. Think I'll run it off my stereo dimmer wire instead. Just clutching at straws, but thinking since the fog dimmer wire turns the switch illumination bulb on and not dimming it(like clock and/or radio) it's causing the issue. Decided I was done pretending to be an automotive electrician and move to the boost portion of the gauge. Perfect, just a plain ol' vac line. I can handle that! Ran it through the firewall and trimmed length. My engine already had a boost gauge and T that I capped during swap. So an easy uncap and install hose and I'm done! I didn't configure my gauge while updating my firmware.. Need to change screen to read boost to test it's functioning.

Small OCD - the gauge bezels are different between the 2. E-mailed AEM to see if I can get a spare from one so they both match.

Hoping to brave the cold tonight and finish the dimmer, run my wideband o2, and get my logs recorded. Then I can start looking at the failsafe wiring from the warmth of the sofa
 
261 - 280 of 502 Posts
Top