Subaru Impreza GC8 & RS Forum & Community banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

I recently bought a 1999 Wagon Sport, which over the last 6 months has needed the usual basic replacements to combat age. I had to replace the original rusted subframe to pass MOT, and it has caused more problems than it has solved. If anyone is able to help me find the root cause of the problem, I would be forever grateful.

So, sourcing replacement parts, I took the sub-frame with arms, shafts, diff and shocks from a 1994 WRX, replaced the diff with my original to match ratios, and decided to use my original shocks. The idea was I would end up my original diff and shocks, and the rest would be donor parts to change the existing drum brakes to rear discs and solve the rusty sub-frame issue.

Everything seemed to line up and fit into place nicely, no real issues after fitting new flexible brake hoses and rerouting handbrake and abs sensor cables. The issue came once the car was lowered back down onto 4 wheels. Something is causing the rear shocks to rub against the inner arch and against the wheels, but I don't know exactly what is causing it. Comparing the two sub-frames, the seem identical. I wandered if the shock mountings on the back of the 94 disk housing are different to the back of the drum housing on a 99?

I've compared the shocks that came attached the to new frame, the are shorter than mine, and have a wider spacing between mounting bolts.

Please help! The photo's show what came out, and what is now in it's place:
 

Attachments

1 - 1 of 1 Posts
Top