Subaru Impreza GC8 & RS Forum & Community banner

301 - 320 of 360 Posts

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #301 (Edited)
block decks nice n shiny using the roloc bristle


.002" no pass!


time to install the viton valve seals


wire wheeled the stupid harness bracket. Gonna coat it


used a brushed al vinyl on the cluster bezel. Not sure if I'm 100% sold on it. Might try to do it with a dip instead.
 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #302


anyone have any extras of these? They hold the top vent on to the dash near the windshield.
 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #306
this company 23 valve tool apparently isn't made for the ej20g heads.
I had to grind the bucket down to fit inside the valve hole and its also not tall enough to gain access to the retainers after the spring is compressed.

I can get a spacer to add some height or I can just get the right fucking tool. Suggestions?



lots of wire wheelin..
probably going to shoot it with some clear coat when I'm finished. block too
 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #308
cleaned the block top and bottom, gonna clear coat it so it doesn't oxidize as soon as shes on the road again





finally got the spring compressor to work. had to stack up a bunch of washers
the seats seem pretty clean so I'm just gonna clean the valves and put in the new seals and call it good.




 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #311


finally got around to tearing into the second head

lapped the valves anyway cuz it wasn't as bad as I thought it'd be




and now I feel that much more confident they'll have a good seal

fresh and so clean


after a good brake clean and air compressor clean out


vitton seals


almost brand new
 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #312 (Edited)
Ran into a small hitch... some of the buckets didn't want to 'spring' back
I'm trying to upload a video but the ej20g v2 buckets have a spring inside the buckets and 6 of them seem to be frozen. I can't seem to get them to loosen up.

Help?

:EDIT: click for video
 

·
Registered
95 impreza wagon
Joined
·
737 Posts
Discussion Starter #318
solved it:

did some more digging. Apparently the 1.8miatas use the same style of HLA. the "stuck" ones are actually just pressurized with oil (how they'll be in actual operation) which is how they compensate for oil temps,etc. I took apart a springy one and sure enough it was dry inside. I took apart the "stuck" ones just to make sure they would move since its been sitting for so long and now everything is bouncy and ready to go back together.

for reference from Logan:
 

·
Registered
'96 OBS
Joined
·
235 Posts
Hey man. Always good to see you doing stuff the right way. It's good to know what I'll have to do eventually once doing things the easy way ends up biting me in the ass. :3 Now it's just a race to see if you finish your car before I find a way to break mine again. :D
 
301 - 320 of 360 Posts
Top