Subaru Impreza GC8 & RS Forum & Community banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey y’all. I never posted because I usually find the answer deep within threads but I’m finally stumped and because it’s NA, coming from only turbo cars, I can’t just easily check the logs so I’m hoping for the gurus to chime in.

The car is relatively stock. Only has Tsudo headers and full exhaust.

Backstory is, car was laid up for a few months untouched. Recently did a maintenance job, new everything. Filters everywhere, oil, fuel cleaner, spark plugs, cables, coil pack, brake pads and tires.

Drove it for a bit and have no CEL and monitors all pass. Got a NYS inspection done shortly after.

Now for the issue and confusion at hand. Finally took the car on the back roads and felt amazing from point A to B. Took the car back to point A and at corner exists coming close to redline, the car bogs for a second and recovers fine. Happened only twice. The first I was confused and the second was to confirm and didn’t try a third because not cool

Fuel cut maybe? I had a half tank of gas. Thoughts?

Pic for fun of the car
Wheel Tire Vehicle Car Hood
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
I wanna give a big Thank you to everyone that responded. You guys are the reason I still believe in this community and forums. No bs, all help, educational, and solutions. You guys are awesome.

For now, I will keep a full tank, maybe swap the pump out to a wrx one and a new sock since I have it laying around and source a baffle tank.

Thanks again!
 
1 - 3 of 3 Posts
Top