Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

· Premium Member
2005 Legacy GT, 1977 Jeep CJ7
Joined
·
1,535 Posts
Discussion Starter · #1 ·
ok so i have a jensen radio/ipod/sim car/usp stero. I had this for over a year and it has been great. However, i connected my ipod and played one of the songs and it started to skip. Now when i try to switch from ipod/usb/or the sim card all it says is "READING" and wont ever play. However my radio still works. Any help would be great
 

· Registered
GM6
Joined
·
169 Posts
I suggest checking out the support section of the manufacturer's website. They probably know more about their products than a 2.5RS forum.

What kind of ipod is it and how does it connect? (AUX in, serial iPod accessory protocol, or USB mass storage?)

If it's a hard-drive based iPod and the skipping is like a CD skipping sounds, your hard drive is going out. Vibrations and moving the iPod while it's in use can ruin these hard drives. I guess they want you to use it while you're stationary. I broke my 4G iPod this way twice, and Apple only fixed it the first time.
 

· Premium Member
2005 Legacy GT, 1977 Jeep CJ7
Joined
·
1,535 Posts
Discussion Starter · #3 ·
yea im having a hard time finding their web site. well the ipod skips and so does the cd and the sim card. i think its the stero crappin out which stinks since its only a year old. its an ipod nano
 

· Premium Member
2005 Legacy GT, 1977 Jeep CJ7
Joined
·
1,535 Posts
Discussion Starter · #6 ·
hahah yea im a dumbass i was spelling their name wrong in google. It appears that its the radio itself. I can buy a new one for $80 so its all good
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top