Subaru Impreza GC8 & RS Forum & Community banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I disconnected my battery so I could clean the terminals. and now that I reconnected it, lights wont stop flashing. When I say lights they are like hazard lights, plus interior lights. They will flash about 5 times, then stop, then start again. THey do not flash when im driving, but they flash when the car is off and the key is out. I have a 1998 subaru outback legacy wagon.
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Hit your remote and it will stop. If you have (or had) an alarm it would be going off too. My guess is you just have keyless entry. It's there so that if you have an alarm and someone gets to disconnect the battery and reconnect it the alarm goes off and locks out the starter. Pressing any button on the fob resets it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
never mind! I found a way to fix it. Thanks for the idea though, it sent me in the right direction.
 

·
Premium Member
Two Mini Coopers!
Joined
·
10,629 Posts
Unless I am mistaken, that's your alarm going off. You either need a remote to dis-arm it, or put the key in the car, then there is a little button on the edge of the dash to the left of the steering wheel which you hold in and then turn the key on.

If that was not it, please post what it was for everyone else! :D
 

·
Registered
Joined
·
49 Posts
under dash there is a little button, turn car to on position, not start it, then hold button for 1 sec. it will stop. happened to me last night.
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
That button is only there if you have the security upgrade to the keyless system. If that button was there and he hasen't been pressing it then he wouldn't be able to start the car. What that button does is disable the starter lock out as well as silence the alarm.
 

·
Registered
Joined
·
49 Posts
i have that button on my car, when i disconnected my battery the parking lights were flashing, but i still drove it out of my garage into the driveway.
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
If you have that button then you must have an alarm, or had one. AFAIK that's the only way it gets installed
 

·
Premium Member
RSTI
Joined
·
6,844 Posts
AARGGGGGGGHHHHHHHHHHH!!!! Brendan I could kill you right now. Dude how'd you do it?!?!?!?!? Christ this sucks.

cheers

garrett


Brendan said:
never mind! I found a way to fix it. Thanks for the idea though, it sent me in the right direction.
 

·
Banned
00, Impreza RS, Silver-t
Joined
·
215 Posts
I didn't know I actually had a factory alarm.

I didn't know I actually had a little black button to disarm it under my dashboard.

That is, at least, until my car wouldn't start last night and gave me the "hazard light show". Today I see the little button, come on here to find out what it does, and BAM... find out that it disables the security system. Awecome. Go rs25.com!
 

·
Registered
RSTi, STi V6, BRZ Turbo
Joined
·
6,318 Posts
actually, if you put the key in the on position and THEN connect the battery, your alarm will not screem at you or freak out in any way.
 
1 - 15 of 15 Posts
Top