Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

·
Registered
98 2.5RS BDP
Joined
·
80 Posts
Discussion Starter · #1 ·
Hey guys, i really need your help. my car been sitting in the garage for 4 months now and i really miss driving it. here's the problem:

one day on my way to work while at a red light (gear is in Neutral) waiting for it to turn green. when i try to put it into 1st it wouldn't go into gear so i try 2nd still wouldn't go. I don't think it's the clutch. Some told me it might be the slave or master so i replace both. I've bleed the clutch twice but it's still the same. It seem my clutch pedal doesn't have enough pressure. Maybe i'm not bleeding the clutch right because it is my first time bleeding a clutch or maybe it's something else. Can someone help me out?
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
Your clutch fork could be broken and not pushing the clutch, have you had someone check to see if the slave cylinder is actually moving far enough? Wow, lots of people with clutch problems lately. ???
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
You need to get someone to see if the slave cylinder is actually pushing the fork first. Although the pressure plate of the clutch could be bad, it is the least likely problem. Here is the order of failure as I've noticed with one being most likely to 3 being least:

1-slave or master cylinder faulty
2-bent or broken clutch fork
3-faulty pressure plate
 
1 - 6 of 6 Posts
Top