Subaru Impreza GC8 & RS Forum & Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
my moon roof works fine sometimes, but when it is hot out I wont work at all. If i press the putton to many times then i have to turn off the car. When I turn it back on it works anain. What could it be?????????????????
 

·
The Thread Stopper
11 WRX, Matte black
Joined
·
5,783 Posts
My Jetta had the same issue. Never did figure it out. My guess is the seal has expanded and creates such a strong vacuum that the motor can't overpower it. I may be waaay wrong, but I like that theory!
 

·
Registered
Joined
·
30 Posts
If you press it and it doesnt work. Push on the sunroof itself a little bit, then press the button again. Might solve your problem, my ol 94' did this. ;) Let me know if it works!
 

·
Registered
04 STi silver
Joined
·
624 Posts
mine is the same way. to get it open i have to push up on it half the time and then closing it i have to keep pressing the button. as soon as it stops working all together ill mess with it.
 

·
un-Banned by RS25.com
2000 SRP 2.5RS Coupe
Joined
·
2,164 Posts
Stiletto said:
My Jetta had the same issue. Never did figure it out. My guess is the seal has expanded and creates such a strong vacuum that the motor can't overpower it. I may be waaay wrong, but I like that theory!
I know your problem. You were driving a Jetta. :naughty:

VW/Audi are notorious for electrical prlblems.

My moon roof chatters while it opens. I've cleaned the rails a bunch of times but apparently I can't clean the part that needs to be cleaned.
 
1 - 8 of 8 Posts
Top