Subaru Impreza GC8 & RS Forum & Community banner

1 - 8 of 8 Posts

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #1 (Edited)
I'M IN THE CLUB!!!!!!! :banana: :banana: :banana:

New to me 2.5RS, picked up August 20th 2017 in the North Bay. The dude didn't care for the car at all and parked it under a pine tree every day, so it was covered in dirt and sap. Wheel bearing is clunking, CEL is on for the O2 sensor, sunroof doesn't work, head gaskets are on their way out, and the clutch is following it out the door. But, I got it for $3200 (which in Bay Area talk means I took the keys and ran) so I'm not mad, especially since the body is in fairly good condition. Plus, the car is stock and unmolested apart from the glass headlights, which makes it 10x better.

List of shit to fix:
  • Wheel Bearing Fixed 11/3/17
  • O2 Sensor Fixed Oct/17
  • Sunroof
  • Head Gaskets Replaced at a shop 11/7/17
  • Clutch Replaced at a shop 11/7/17
  • Engine mount Replaced with some out of an 04 RS
  • Brakes are squealin' They stopped squealing. Don't know why but they just did.
  • Brake master cylinder is leaking
  • Rear O2 sensor isn't giving voltage so can't pass smog Connector was bad. Replaced and it's good to go.
  • Cyl 4 Misfire - probably bad coil pack
  • Front CV axle boots are ripped
  • Front left tie rod boots are ripped
List of upcoming mods
  • Yellow fog overlays
  • 20mm Swaybar w/upgraded mounts and poly bushings
  • Axleback exhaust, hopefully a Stromung
  • Mud flaps
  • Considering a ganzflow style intake
 

Attachments

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #2
When I bought it, sitting next to my Legacy L Wagon



Just scrubbed down the wheels during the eclipse... but who needs an Eclipse when you have an Impreza?

 

·
Registered
Joined
·
3 Posts
Sweet deal on a awesome clean coupe, that's rare! And you're right, in California for a car like that you stole it :)

Sent from my XT1575 using Tapatalk
 

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #4
Not an update, just putting down some thoughts.

I have to hold off on any work on the car until I get the impreza outback in my backyard out of there. Pulled the engine and it was corroded to shit so I'm looking for a new phase 1 ej22 right now.

After that I'm going to fix the Impreza so that I have a reliable daily when I sell the wagon. Wheel bearing sounds like an ass job since I'm not willing to invest in the tools for it, and I'm worried about doing head gaskets myself.. I'm wondering if I could remove the components from the car (entire hub, whole engine) and bring those in to a shop to cut down on labor costs. Clutch and engine mount I feel somewhat confident doing myself, especially if the engine is out of the car.

Finally I'm considering body upgrades. Someone keyed the trunk of the Impreza because the guy I bought it from was "unliked at work" whatever that means. I REALLY want that JDM WRX trunk lid, and a bigger wing... No idea where to start looking. Anyone got any tips?
 

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #5
Alright, so some updates on stuff

Starting school soon so when I do fix the headgasket it needs to be in a shop. No time. When I get that done I should probably do clutch and timing belt as well. Overall I was quoted $3000 to do it after another shop told me they just straight up don't do headgaskets past 170k. I have like $300 in my bank account so I'm gonna be working for a while to save up. I ordered wheel bearings and hubs for both back wheels. Going to Lowe's soon to get the stuff to make a home made bearing puller... but I'm thinking I might just go to a shop and get the old stuff pressed out and the new stuff pressed in.
 

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #6
I keep getting a CEL for my rear O2 sensor, P0136. I was throwing both that and a cyl 4 misfire, but now I am just getting a P0136. I replaced both the front and rear sensors and it came back again. I lost my multimeter a long time ago and finally I found myself in need of one, so I overnighted it from Amazon. It'll be here tomorrow so I can check the harness. In the meantime, any ideas for what it could be? Sensor is a Denso, exhaust is stock, hell, whole car is stock. I don't see an exhaust leak (did the whole soapy water trick) and the wiring looks fairly intact. Need to fix it soon so I can smog the damn thing and get it registered!!

Oh ALSO, the car fucking shuts off for half a second while I'm driving if I bump the aftermarket alarm system, I've almost died twice now. All the lights and everything just die and then come back on. Looking in to how to remove it.
 

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #7
Alrighty! Some updates...

The car shutting off was definitely the alarm system. Clifford system from when the car was bought. I tried to contact them and they told me to take it to a professional.

....nope.

Got down there with some wire cutters and the wiring diagram. Just started pulling shit out. TONS of sensors on this thing. Range extender, window tampering microphone, every door, trunk, hood, all that crap. Honestly, it would have been great to keep, but... it tried to kill me. One by one I ripped them all out, reconnected the ignition and the starter cables and it started right up. I weighed all the wires and everything... 4 pounds of alarm system in the car. Insane. Eventually I'll wire up some kind of kill switch and do it right so I don't die.




I did the wheel bearing this week. Lifted the car, pulled off the whole knuckle, took it to a machine shop and got the bearings pressed out and the new ones in.

Got a little surprise: Took off the rotor and got a look at the ABS tone ring:



Now I kind of get why I was having ABS issues. I poked at it and one of the hex bolts fell out. Oops! Sensor was bent at a 45 degree angle presumably from being whacked repeatedly for months. I'm going to disable ABS for the time being. No snow where we are so I should be cool.

Bonus pic! Just to make you all jealous, my original 1999 (MY 2000) lateral link bolt, completely rust free! Took me all of 1 minute to remove, most of which was just positioning the wrench on the other end. Oh, California, how I love you.



Brought in the knuckles. I watched him press them in and out, one of the hex bolts snapped and I had to pick up another from Pick n Pull. Almost got the ABS sensor off but I accidentally used the wrong wrench and stripped the bolt. :bonk: Pic of the new hubs and wheel bearings in the knuckles (before I got the hex bolt):



Second bonus pic (2 pics I guess): The shop I went to had a project AE86 Corolla with a Honda s2000 engine in it :drool: makes like 250 N/A!! Maybe I should buy a honda.... but nah :projectsti.com:




New bearings on the car feels incredible. Havent felt any issues with the thumping I was having on left turns, the noise is completely gone... it's like a new car!!

Three hours after fixing that, I dropped the car off at the shop for clutch, headgaskets, and timing belt. I'll have it back Tuesday. THAT will feel like a brand new car... I'm beyond excited!

I'll post some pics when I get it back. Anyway, here are a couple other bonus pics of her next to some friends I found in the wild..



And in my school's parking lot:



Last thing! The girl I sold my wagon to told me her shifter was feeling loose. I told her to swing by, and I checked it out...



:eek::eek::eek:

Nut came off the top and the bolt was just hanging out the bottom. Didn't even make it through the top. Could totally have fallen out... this was my fault. First thing I ever did on a car was fix the shifter slop on this, and I didn't know what threadlocker was at the time. Put some on this time... could have been bad. You could move the shifter in circles!

Updates soon!
 

·
Registered
00 2.5RS Coupe
Joined
·
46 Posts
Discussion Starter #8
Got a call from my mechanic today. Should be good to be picked up tonight! They got a good look at some of the other stuff wrong.

In no particular order, the brake master cylinder is leaking, the misfire is still present (cyl 4) the rear main seal had a leak and was replaced, front CV axle boots and left front tie rod boots are torn.

Few questions for you guys, assuming anyone is reading this thing:

Is the master cylinder worth upgrading? Or should I keep the stock size?

Since spark plugs/wires are relatively new, I'm gonna replace the ignition coil pack next. Worth upgrading? And-- if I'm replacing it with OEM style, should I go OEM or some rockauto aftermarket?

Hopefully I can get this thing smogged soon. These out of date stickers are gonna get me in trouble soon.
 
1 - 8 of 8 Posts
Top