Subaru Impreza GC8 & RS Forum & Community banner

761 - 780 of 780 Posts

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #763
Got the XTi suspension buttoned up. Now just trying to organize the garage a bit. One corner at a time.
 

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #769
I more than made up for it with the bedliner!

Got started on the car last night.

So much corrosion. Sitting just destroys cars.






Fixed the oil leak on the turbo, I hope. Crush washers aren't quite perfect.




Started the install of the Beatrush front bar and did some more skid plate work.





I also replaced the IACV with a different one as I think I fried the other one by hooking it up to an injector signal. Also torqued the Map sensor feed and messed with the bracket for the throttle cable. I have a different throttle body that I'm going to swap on eventually but I want to get the car started again first.




It also appears I have an oil leak. It seems my oil level is way too high but using a SOHC heads on a STI pan I'm not sure how accurate the stick is.


I can't imagine why it is leaking....




I did try to start the car. I had no fuel pump / pressure and when I went to crank it the car shut off completely. Not sure if it's a battery issue or something more.
 

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #771
You need to come to CA, get a $1000 beater, go home, swap the shells and sell the red shell with the CA NA parts.

Well worth it...
I have a rust free shell, remember?
 

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #773
It's still in the garage. Haven't been able to touch it unfortunately. It seems everyone car needs work when winter hits. Not to mention the 6 feet of snowfall we've gotten. I did get a pupper though!






Now I need to figure out why there is absolutely no power going to anything. I haven't done any diagnostics but I am still baffled. Last year when I tried to turn it over it cranked. Now there is no power going to anything.
 

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #774
Just saving this information for the future:

Front Axle Shaft - 28021AC210
Rear Axle Shaft - 28021FA180
 

·
Registered
2.5RS, STI, BRZ, ZL1 vert, X5D
Joined
·
178 Posts
Looks like I'll be able to use the JDM PS pump with the APS hard inlet. The bolt interferes slightly but I think that can be remedied easily with an angle grinder.



Interesting.. Curious to see if it still fits OK once you have the IM on. I've only just started reading your thread so maybe I will find out shortly (y)
 

·
Registered
2.5RS, STI, BRZ, ZL1 vert, X5D
Joined
·
178 Posts
Interesting.. Curious to see if it still fits OK once you have the IM on. I've only just started reading your thread so maybe I will find out shortly (y)
I guess it didnt work out.. Any reason you switched away from the hard inlet pipe even after you change out the PS pump?
 

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,795 Posts
Discussion Starter #780
Interesting.. Curious to see if it still fits OK once you have the IM on. I've only just started reading your thread so maybe I will find out shortly (y)
Ended up going a completely different direction with a Spec C intake manifold, soft inlet and Outback XT power steering system. The OBXT system is the answer for packaging problems in my mind.
 
761 - 780 of 780 Posts
Top