Subaru Impreza GC8 & RS Forum & Community banner
1 - 7 of 7 Posts

·
Registered
2000, 2.5 RS, BRP
Joined
·
269 Posts
Discussion Starter · #1 ·
hey guys i just replaced all my valve and spark cover gaskets, i changed out my old spark plugs and wires, and my fuel filter, and now when i try to start my car it wont turn on, it sounds like it wants to turn on but it doesnt ignite..


any suggestions to what may be causing this?

thanks
 

·
Premium Member
2002 2.5 RS-T
Joined
·
2,960 Posts
hey guys i just replaced all my valve and spark cover gaskets, i changed out my old spark plugs and wires, and my fuel filter, and now when i try to start my car it wont turn on, it sounds like it wants to turn on but it doesnt ignite..


any suggestions to what may be causing this?

thanks
after you change fuel filter it will take a little longer to start....hold the key in on position for 10-15 seconds, then crank it....might still take a few more cranks than normal...but should start


if that dont work check if you're getting spark.....pull a plug boot out...stick a wire in it and hold near a ground(pretty much any metal..) and have someone crank the car....BE CAREFUL NOT TO SHOCK YOURSELF...it probably wont kill you but it doesn't feel nice lol....

there may be a better/safer way to test but that's what i've always done....and im still not dead

if you dont have spark on all 4 then thats your problem....
 

·
Registered
Joined
·
12,196 Posts
Make sure the spark plugs are tight enough (snug) and the boot of the spark plug wire is popped in. A lot of times it may feel as though the boot is in, but you have to push somewhat hard and you'll hear a little click. Also make sure the fuel filter is in the right way and the lines are hooked up correctly.
 

·
peon
shitty shitty bang bang
Joined
·
2,583 Posts
after you change fuel filter it will take a little longer to start....hold the key in on position for 10-15 seconds, then crank it....might still take a few more cranks than normal...but should start


if that dont work check if you're getting spark.....pull a plug boot out...stick a wire in it and hold near a ground(pretty much any metal..) and have someone crank the car....BE CAREFUL NOT TO SHOCK YOURSELF...it probably wont kill you but it doesn't feel nice lol....

there may be a better/safer way to test but that's what i've always done....and im still not dead

if you dont have spark on all 4 then thats your problem....


what he said:hydrogen:
 

·
Registered
2000, 2.5 RS, BRP
Joined
·
269 Posts
Discussion Starter · #7 ·
well i will check it out tomorrow morning, my cars parked outside my friends house because i had to run to work so i couldnt even really trouble shoot,

i thought it might be the fuel filter as well but who knows, im going to wake up super early tomorrow before work and try to trouble shoot, and redo all the spark plugs n wires just to make sure
!!
 
1 - 7 of 7 Posts
Top