Subaru Impreza GC8 & RS Forum & Community banner

321 - 335 of 335 Posts

·
Registered
Cheap Kitchens
Joined
·
1,896 Posts
Discussion Starter #322
Quarantine hasn't affected me like most people, I worked over 50 hours last week and almost 60 the week before. Despite this, I have been getting a lot of stuff done at home too. My deck project is nearly done and it looks amazing, I set up another computer in the office for my wife to work from home, I got a great dane puppy and I also put in some work on the Impreza



The last plug I had to convert to 99 spec was the fuel tank and with help from the diagrams the merge was pretty straightforward match same colors with just a couple exceptions, the fuel pump controller is now up by the dash and that's where the fresh white wire is going



I got the sensor wires and the boost gauge hose run through the firewall so I could fit the dash in, I ordered the long hose kit from WRXtra and I would say it's more than long enough to satisfy



I also got the oil pressure sender kit from WRXtra hoping the alternator would fit better and it does but the factory pressure switch will not fit in the rear port so close to the bpv hose, I want to keep the factory switch so it just wasn't meant to be



This is the way the kit was meant to be installed anyway and it just made everything so much easier, I'm willing to sacrifice a little accuracy just to be done with this and move on



Since I was having so much trouble with the top hose fitting it made a lot of sense to cut it for the temp sender, made the hose much easier to fit and I can expect a fair amount of accuracy from this location



The aos just really doesn't want to fit and every way I try to fit the hoses they come really close to heat or sharp edges, the can itself has such a small area it can be in and I have spent a lot of time trying to make it work but it doesn't seem possible



I want to revisit these header tank hoses but for now it will have to do, I completely ditched the power steering cooler and maybe it will make a comeback if for some reason it feels necessary



I ditched the aos and just put in the factory pvc so, with the intercooler in, all that's left is to hook up the boost gauge hose T to the bpv reference hose and connect the ground wire to the battery then I can flash the tune



I primed the oil pressure a bunch by cranking it over with the non chipped key then fired her up for the first time since 8 August 2015, that's almost 5 years of sitting so it burned a lot of oil but so far no check engine light



All the oil burning turned my muffler into a milkshake but it has stopped burning at idle, when I drove it around it still puts out smoke if I get it close to boost so I'm hoping the rings find their seats again soon. There's just so much to shakedown I'm really hoping everything works out but I'm expecting there to be setbacks, thanks to everyone for your help and support I couldn't have done this without the people willing to share their knowledge on forums
 

·
Registered
Cheap Kitchens
Joined
·
1,896 Posts
Discussion Starter #327
Here's some of the other thing I've got going on in pictures





New puppy's name is Blue and she's purebred Great Dane



Toyota made it ridiculously hard to change the oil in the new 4runner, a big fuck you to the home mechanics






I reused as much wood from the old deck as I could and added a water channeling membrane, The new beam is 6x10 and the 4x12 stringers are the old beam and ledger. Why anybody would use a 4x12 for a ledger I cannot explain, they also used 2x6 and subfloor sheets for the shed roof



New fish's name is Spike and he's a freshwater puffer



Drippin
 

·
Registered
2000 RS Coupe
Joined
·
190 Posts
Damn! 5 years...had some free time at work and just finished reading your build thread to date. Your dedication to this build is impressive. You've got a lot of really cool parts and customization, in addition to swapping the FXT drivetrain and harness merge. I wish I had parts yards full of Subarus where I reside. Seems like you've been able to source a bunch of choice parts form there. Keep up the good work.
 

·
Registered
Cheap Kitchens
Joined
·
1,896 Posts
Discussion Starter #331
Try having a grocery store.
Some of us haven't had a day off in a month.
Thanks disgusting hoarding people.
I am a meat cutter so I know it. To top it all off we are in contract negotiations right now and, among other bullshit things, they want to cut our sick pay rate down to the state minimum... during a pandemic... when we have massive support from the public... The CEO sends thank you emails out every other week though and that makes all the difference

Back to this nightmare project, the big issue is oil leaks. I'm sure sitting for 5 years was not kind on any of the gaskets and seals which is why you should always seal up a motor for storage properly even if you think that it will be a super quick turnaround because you are only kidding yourself and all your projects take way longer than they should. Maybe I'm just projecting, but it isn't a bad idea



First off, oil is leaking from the pressure sender hose so I tightened that up as much as I could in the limited space



When I took off the intercooler noticed a lot of oil in the elbow so makes me think the old pcv is not doing it's job



There wasn't so much oil going through the intercooler though, when I took off the throttle body I saw a bunch of oil dripping into the intake manifold from the pcv hose



The pcv from the Forester was tired and I remember replacing it on my wife's XT solved the oil consumption issue on that car so even though it feels like throwing a glass of water at a forest fire I replaced it with a new one



I was concerned about the bpv hose coming into such close contact with the pressure sender hose so I tied a piece of rubber hose around it to insulate



The milkshake is gone and now I have a lot of wet oil in the exhaust, it doesn't smoke as much now but it is sure leaking



The left side looks dry but the right side it looks like oil is coming from the valve cover, the oil cooler, the timing cover...



For sure coming from the oil cooler



Oil coming down the exhaust ports on both sides seems to be only the forward ports though



Right side not as bad as the left, I'm wondering if the crankcase pressure is so great and that's why it's leaking from everywhere but I didn't do the test of taking the oil fill cap off because I'm retarded. Today will be putting the exhaust back on and running it on the jack stands to see if there is just a ton of blowby, I'm hoping it isn't turbo seal but it seems to be a combination of failures
 

·
Registered
Cheap Kitchens
Joined
·
1,896 Posts
Discussion Starter #333
I ran it again with the oil cap off and it didn't feel like a lot of pressure, some pulsing for sure but doesn't feel like a ton of blowby



With the intercooler off it seems even a brand new pcv isn't able to stop oil getting sucked up and that's what I expected but I bought one anyway because I am stupid



This time a lot of oil made it into the intercooler so I have to clean that out now



Pretty sure oil is not supposed to pool up here, the pcv seems to be injecting oil at all points of contact



The vf39 tune from Cobb doesn't seem to be able to keep up with the vf48, obviously the fact it is an ots tune and for the wrong turbo I'm not expecting AF to be perfect but I'm seeing high teens and 20's with learning as high as 18%



The codes are starting to roll in and the dbw pedal codes I'm a little confused by and not sure how to reset it's range of motion, I'm hoping the misfire in cylinder 4 is just from so much oil getting into the intake



So it's pretty clear I need to install the aos and in trying to see how the hell I'm going to fit the crawford in there I found a video of the install on Bucky Lasek's at Crawford but 99% of the video is guys standing around chatting, the install is done in superspeed at the end without narration or anything helpful at all so thanks for the quality content Crawford



Another video of his car had some good stills of the engine bay and they were a little more helpful, I could probably find better images if I was connected on social media but I'd rather have mental health



This is the ideal location but my Cusco strut bar is right in the way, can't have both Crawford aos and Cusco strut bar at the same time it seems



To position the aos in it's ideal location an adapter plate is needed, I used a thick mending plate and painted it black



There isn't a better location than this, I will miss my strut bar dearly but I only wanted it for aesthetic reasons
 

·
Registered
99'RS w/EJ205, 16'340i 13'Volt
Joined
·
973 Posts
I just went thru the whole build. wow. i applaud the persistence. thanks for shedding light on the cusco underbrace. After installing mine, I knew something was wonky because there was a binding sound but I blamed it on worn bushings. I put in the whiteline anti lift bushings and new control arm bushings and there is still some binding. It doesnt help that I dont know whatever front subrame is on my car, but I assume it is from the donor 02 WRX that my EJ205 came from.
 
321 - 335 of 335 Posts
Top