Subaru Impreza GC8 & RS Forum & Community banner
1 - 11 of 11 Posts

· Registered
2005, Subaru, Impreza 2.5 rs s
Joined
·
147 Posts
Discussion Starter · #1 ·
I had an injen intake installed (professionally)on my car and after cranking it up I drove it around and my car keep getting close to shutting off, then the Check Engine Light came on, I took it back and everything was installed right, took it to a second guy which confirmed everything was installed right, My check engine light codes are P0506(idle control system), p0108(Manifold Absolute Pressure), p0700(transmission control system), and p1718(manufacturer controlled transmission) HELP!!!
 

· Registered
2017 STi
Joined
·
14,451 Posts
Damn?! The only thing I can think of is getting your ECU reflashed but I would think you wouldn't need that with being completely stock. It could be that your ECU needs to adjust to the new intake that you put on. When I put on my CAI I had sort of the same problem you had, but I drove it around for a while and the CEL went away, and all was good. My car felt like it was going to die in first gear.
 

· Banned
01 Silverthorn 2.5rs
Joined
·
674 Posts
Well, was just wondering if he had a shop do it, or someone help him. There is no way you should be blowing 4 codes because of an intake...

Are the 05's MAF, or just MAP? Shop could have fouled up your MAF.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top