Subaru Impreza GC8 & RS Forum & Community banner

1 - 5 of 5 Posts

·
Registered
Impreza 2.0 1998
Joined
·
3 Posts
Discussion Starter #1
Hello. I am in a struggle of fixing my airbag light wich is constantly on in my 98 impreza wagon.. I have had a bad clockspring wich i replaced and now The horn works well but The light is on still.. Trough The diagnostic connector i read The codes 12 and 14 and when i try to clear them The airbag light does not flash but dims a little and then comes back again... Does anybody know where to look and how to try and solve The problem..? I also tried replacing The airbag module wich did not help either...
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
Can't find anything specific for the 1998. Slightly newer subaru shows code 12 being a fault with the passenger side, and code 14 doesn't exist.

Alright alright, FOUND IT. I'll PM you a link to a pdf of the diagnostics section from the 1998 Service Manual.

Just a guess but it looks like something might still be unplugged and they could both be related.
 

·
Registered
Impreza 2.0 1998
Joined
·
3 Posts
Discussion Starter #3



Thanks again for the link silverton! Now i found all connectors and they are all connected.. But i noticed that on the airbag control unit there are two contacts wich stay not connected to anything when the connector is in.. Could there be a piece missing wich secures the connector to the module and completes the circuit?
 

·
Banned
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,236 Posts
No pins in the other plugs, and it's dirty AF, looks to me like nothing has ever been connected in those other two
 
1 - 5 of 5 Posts
Top