Subaru Impreza GC8 & RS Forum & Community banner
1 - 4 of 4 Posts

·
Registered
98 Impreza L/WRX VF39'd
Joined
·
294 Posts
Discussion Starter · #1 ·
so my swap has been running fine, then the IACV went bad cleaned it and it didnt help so i paid $227 for a new one.. it fixed my bouncing idle issue but now i have a higher idle like 900-1100 at a stop light. Also my RPM's jump when i shift not all the time but enough to notice like i'll shift at 3k and it will jump to 4k.

I am still getting two codes P01507 and P0507 but the IACV is new could I have a bad TPS? I looked for a vaccum leak cannot find one. The car was running fine and idling fine before the IACV went bad, I have reset the ECU numerous times, and adjusted the throttle cable a few times. Could the TB itself be bad? Any suggestions would be helpfull..
 

·
Registered
98 Impreza L/WRX VF39'd
Joined
·
294 Posts
Discussion Starter · #3 ·
bump anyone else have some insight?

I just replaced the Neutral Safety Switch and still having this issue, P0507 seems to have gone away now i just have 1507 still but with a new IACV this is driving me up the wall.
 

·
Registered
92 Crown Vic
Joined
·
629 Posts
the code numbers means crap. what do the numbers mean then you might get some help. but it sounds like a mass meter. i know you can disconnect the meter and it goes to limp home mode - assuming you have a stock ecu. and i wouldn't drive very far with it disconnected, but that is a way to see if that mass meter is it (assuming you have a mass meter - mass air flow sensor)

james
 
1 - 4 of 4 Posts
Top