Subaru Impreza GC8 & RS Forum & Community banner

181 - 200 of 200 Posts

·
Registered
Joined
·
17 Posts
Subaru 2.2L Auto 1999

I have hesitation problems and they just started recently. It hesitates very badly from stop to about 40km/h then the power just kicks in. A few days ago, I started my car went to work and got a CEL light. #325 Knock sensor circuit low. When this happened my car accelerated normal. The CEL light went away later that day. Hesitation started to happen again.

(Spark plug tube gaskets were replaced last year and most likely not leaking)

Knock sensor was replaced in about october ( maybe cause? )

I noticed that sometimes when I drive my coolant temperature gauge spikes to the maximum, and then after about 5-10minutes of driving it goes back to normal. ( maybe cause? )

Things that have been replaced within the last year or two.

Spark plugs
Spark plug wires
Fuel filter
Oxygen sensor
Knock sensor

Help!
 

·
Registered
Joined
·
8 Posts
So in my hunt to track down the reason for my hesitation I have done most of the suggested things. My car hesitates with about 20% throttle, or around 2000rpm. It will bog down when I get to that point, if I floor it past that it will stumble for a second then take off. I have changed my plugs and wires, pcv, valve and spark plug gaskets, o2 sensor, coil pack, needed a new cat which was put on this weekend, fuel filter, seafoamed twice. No codes at all once I changed my cat. Would an IAC valve or knock sensor do that? Not really sure what it could be at this point.
 

·
Registered
2000 2.5rs coupe SRP
Joined
·
9 Posts
I have a 2000 rs and it hesitates at mid -half throttle at low rpm but then picks up and goes like it should at about 3000 rpm. It has a new knock sensor, cat, intake air temp sensor, 2 new o2's. No cels. HELP
 

·
Ex-Mooderator
2001 RSTi, 2011 WRX Hatch
Joined
·
3,231 Posts
I have a 2000 rs and it hesitates at mid -half throttle at low rpm but then picks up and goes like it should at about 3000 rpm. It has a new knock sensor, cat, intake air temp sensor, 2 new o2's. No cels. HELP
How is your plug gap?
 

·
Registered
GC8 - 1997 - 2lts - silver
Joined
·
3 Posts
Very interesting topic this .

Well, in my case (one EJ20 sohc ) had a great hesitation on acceleration and ease the pedal he choked , cut as without any acceleration .

After some testing , I found the adjustment on TPS , like the FIAT Tipo here in Brazil , which needs to be adjusted TPS for a smooth operation.

After a read in the manual, and with the aid of a multimeter able to regulate the correct voltage and the problem was solved

Now the car responds much more to accelerate, has no hesitation or failure.
 

·
Registered
96 1.8 coupe, 01 2.5RS Sedan
Joined
·
2 Posts
SOLVED HESITATION:

1996 1.8 Impreza - all stock except UEL header, custom catback. new cats.

Hesitation:
- mainly at low RPMs (0-3000)
- 75% throttle = sporadic severe misfire/hesitaion until full power at ~3500rpm
- inconsistent occurence, slowly becoming more consistent / often

Timeline:
- new spark plugs (~.041", old ones at .048-.054")
no change
- new fuel filter
no change
- installed old wrx steering wheel
no change?!
- new coil pack
- new spark plug wires
no change
- new air filter
- new pcv valve
- new upstream O2 sensor (sensor 1, P0130)
- slightly loose terminal @ battery (+) terminal cleaned and new hardware
- repaired some slight exhaust leaks, 1 at head/header, 1 at header/cat1, one at cat1/cat2
- HESITATION GONE

Conclusion:
Probably the FRONT O2 SENSOR

Sorry I didn't really narrow it down by changing one thing at a time, but I'm fairly certain the front O2 sensor was the culprit, given the code and it's condition. The old one was beat up from the project of removing it from the old cat(original).

- Andy
 

·
Registered
Joined
·
2 Posts
Just thought I might add, my hesitation was caused by a dirty fuel pump sock and a fuel tank literally an inch full of rust/sediment.
Unreal what these cars will run through.
Cleaned the sock and cleaned the tank out (several hours worth of scrubbing and about a lot of fuel) and the car has literally never ran better.
Thanks for this handy thread :)
 

·
Registered
2001 RS Coupe
Joined
·
9 Posts
Still having hesitation under load after:

New plugs and wires, new valve cover gasket, spark plug tube gaskets, PCV valve, grounding kit, new stromung hi flo cat, new fuel filter. No CELs.

What should I check next?

Also still get rough idle for a couple seconds after filling with gas.
 

·
Ex-Mooderator
2001 RSTi, 2011 WRX Hatch
Joined
·
3,231 Posts
Still having hesitation under load after:

New plugs and wires, new valve cover gasket, spark plug tube gaskets, PCV valve, grounding kit, new stromung hi flo cat, new fuel filter. No CELs.

What should I check next?

Also still get rough idle for a couple seconds after filling with gas.
What are your plug gaps set at?

Did you leave them pre-gapped, or did you change it?
 

·
Registered
2001 RS Coupe
Joined
·
9 Posts
Still having hesitation under load after:

New plugs and wires, new valve cover gasket, spark plug tube gaskets, PCV valve, grounding kit, new stromung hi flo cat, new fuel filter. No CELs.

What should I check next?

Also still get rough idle for a couple seconds after filling with gas.
What are your plug gaps set at?

Did you leave them pre-gapped, or did you change it?
I didn't touch them, it said they were pre-gapped for my car at .044"
 

·
Registered
'01 RS+t STM
Joined
·
1,190 Posts
I found it while working at a dealer. but the update pack reads, "P0031 P0130 P1133 Back fire P1445 P0065 Pinging After burn P0172 Hesitation P1443 P0172 P0065" Has to be done through a dealer with an ssm3. Good luck though, I had to figure it out on my own, no one in the shop remembered how to use the damn thing. lmao
 

·
Registered
2001 RS Coupe
Joined
·
9 Posts
I found it while working at a dealer. but the update pack reads, "P0031 P0130 P1133 Back fire P1445 P0065 Pinging After burn P0172 Hesitation P1443 P0172 P0065" Has to be done through a dealer with an ssm3. Good luck though, I had to figure it out on my own, no one in the shop remembered how to use the damn thing. lmao
Do you have a link to more info? Was this an update put out by Subaru? If so I'd expect it to be documented better somewhere.
 

·
Ex-Mooderator
2001 RSTi, 2011 WRX Hatch
Joined
·
3,231 Posts
I didn't touch them, it said they were pre-gapped for my car at .044"
That's supposedly too much for our coilpacks, at least according to the manual.

Try 0.039-0.040

I spent 8 months troubleshooting misfire issues on 2 cylinders, only to find that 0.044 is out of spec for the 2000 RS's coilpack, even though the spark plug replacement part subaru calls for comes pre-gapped to 0.044.

-- Dave
 

·
Registered
2001 RS Coupe
Joined
·
9 Posts
That's supposedly too much for our coilpacks, at least according to the manual.

Try 0.039-0.040

I spent 8 months troubleshooting misfire issues on 2 cylinders, only to find that 0.044 is out of spec for the 2000 RS's coilpack, even though the spark plug replacement part subaru calls for comes pre-gapped to 0.044.

-- Dave
I'm not having any misfire issues.

I'd assume I'd see a CEL if I was.

From what I've been reading, next I wanna check my front O2.

Forgot to mention I also have a backfire once the car is warm.

I have ebay UEL headers, Stromung hi flow cat, Stromung midpipe (no resonator), and stromung single tip.
 

·
Registered
2001 RS Coupe
Joined
·
9 Posts

Attachments

·
Registered
2000 2.5 RS, Rallye Blue
Joined
·
14 Posts
I have pretty much always had a hesitation issue in my 2000 RS.

I have one potential clue, maybe one of you can make something of it: if the battery is disconnected for service, resetting the ECU, the car drives great. After a couple of days of the ECU "learning," the hesitation returns.
 

·
Registered
'01 RS+t STM
Joined
·
1,190 Posts
Wonder if it was WWF-89.

01 RS ECM Reprogramming? - NASIOC

Would a dealership still be able to perform this reprogramming?
I believe that is the one, though the current update might even be newer. Depends though, no one at my dealership could remember how but I was able to get it done. They can't use the current DST-i box, they have to use the older interface and it has to be powered. Thankfully the current laptop's we use have a power adapter that also plug in the older boxes.

I have pretty much always had a hesitation issue in my 2000 RS.

I have one potential clue, maybe one of you can make something of it: if the battery is disconnected for service, resetting the ECU, the car drives great. After a couple of days of the ECU "learning," the hesitation returns.
pm the last six of your vin and i can see if that wwf-89 tsb was officially completed on your car, if it wasn't you might see if you can get it done. My car had your exact symptoms, and they are completely gone with this ecm reflash. Even the first time I got it on to the road after doing the flash i was like "holy shit it's gone!!!"
 
181 - 200 of 200 Posts
Top