Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

· Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
hi everyone,
I am having a cel problem and an idle surge. the engine is reving up and down during idle and it's giving me a cel P0108( MAP/BARO circuit High Input)
want am I suppose to do to stop the surge and what cause this CEL P0108 to pop up? Please if anyone have any idea what and how to fix this you'll be my hero... thanks guys
 

· Registered
2000 Impreza 2.5RS
Joined
·
25 Posts
i had the same problem in my 00 rs and was told to check vacuum lines and check the connection between the sensor and the ecu. I did that and changed my fuel pump and the idling was fine for a while but just recently started back up again. If you figure anything else out let me know please.
 

· Registered
92 Crown Vic
Joined
·
680 Posts
well obvious answer would be a baro sensor bad. but as Dragonslayer688 said check for air leaks. all those small vacuum lines, check your wiring to the sensor and the connector.
if all else fails go to a subaru dealer or at least call and talk to one.
james
 

· Registered
Joined
·
207 Posts
**Raising from dead** Just saw this problem last night on my '97 Outback Sport. Trying to get it road-worthy again and just need to ride it out for emissions. Currently running a Ludespeed Stage II turbokit. This code popped up after doing a WOT run.

Flagging this so I can refer back to it again. Will look for leaks tomorrow.

Point of reference: http://www.obd-codes.com/p0108
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top