Subaru Impreza GC8 & RS Forum & Community banner

1 - 17 of 17 Posts

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #1
this is an 05 rs wagon:

i put on a k&n cone with a kartboy maf adapter, with a silicone hose between the torque box and the maf. ever since, every once in a while when i go from a dead stop in first gear and mash the gas, the car will electronically bog itself for a half second and then kick in and go... i have 400 mostly highway km's on the new intake. i reset the ecu the first time with forgetting to connect maf harness :stupid: but then re-reset with it connected and had no problems.

any ideas????
 

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #3
i figured that had to do with it, but it never did it before i put on the new filter/adapter. it did it again twice today, once on a lauch at autox, and once on the way there...

this is getting a little annoying because what if i have to get out of the way for some reason and all of a sudden, i lose a whole second because my ecu decides to cut the throttle.

wtf!?!?
 

·
Boxer rumble FTW!
2005 Subaru Impreza 2.5 RS
Joined
·
621 Posts
make sure all the vacuum lines/hoses are connected good and nothings missing(open unused ports) and maybe the kn filter had to much oil applied to it that may have fouled the maf sensor. or just because of the ETC elect throttle control being picky. only things i can think of.
 

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #5
ill have to check out of the filter for sure, because that's the only thing that can be the problem. i never touched any vacuum lines and the dbw systam has never done it before.
 

·
Boxer rumble FTW!
2005 Subaru Impreza 2.5 RS
Joined
·
621 Posts
^^ if the filter is pretty soaked with k&n oil then check the maf sensor probe for any contamination. if it has stuff on the maf sensing wires then spray them clean with a little intake carb cleaner and let it dry for a while before you drive it. then you will see if it fixed it. dont forget to wash and lightly apply some oil to the A filter before you confirm the fix.
 

·
ok terrific.
'95 STi RA rep, rhd yo!
Joined
·
5,207 Posts
Do you have a 3/4" hose going from your intake to the side of your manifold? If you do, check to make sure that it seals perfectly. A slight leak, a crimp, or a difference in hose size will cause the car to bog at low rpm's if you romp on it, and it's usually accompanied by dark smoke out of the exhaust.
 

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #8 (Edited)
drummerRS2505 said:
^^ if the filter is pretty soaked with k&n oil then check the maf sensor probe for any contamination. if it has stuff on the maf sensing wires then spray them clean with a little intake carb cleaner and let it dry for a while before you drive it. then you will see if it fixed it. dont forget to wash and lightly apply some oil to the A filter before you confirm the fix.
the A filter? :confused:

its weird how it bogs. itll go for a half second, and then bog a split second, and then go as usual. it doesnt just wait, it goes then bogs quickly (as if i let off the gas COMPLETELY) then goes again.

i dont have any vacuum lines attached to the intake, never did.

the only thing i changed was i removed the whole snorkel assembly + the airbox, tube between TB and maf (replaced with silicone hose). then threw on a kartboy maf adapter with a USED k&n filter (may be improperly oiled by previous owner but doesnt seem to be soaked, how can i tell?)
 

·
Registered
95L Coupe
Joined
·
143 Posts
Im having this same exact problem. Stock 05 RS Sedan. Exaclty as you described it. Only from a stop does it happen and just started happpening recently for me only after the car has warmed up. Ill look into the hoses but its stock and hasnt been touched. Just Saw Maxi's post no Nasioc wondering if you got a CAI yet and if it worked out.

How about me and my completely stock, bone stock, stock stock RS?
 

·
Registered
Joined
·
4,360 Posts
Definitely sounds like a possible contaminated MAF or an improperly reset ECU. Installing an oiled-style filter in a short ram configuration on a MAF-equipped car is a no-no, it's a very sensitive sensor, and it's very easy to fuck up an ECU reset.

ECU Reset:

1. Disconnect Battery

2. Pump brakes for 60 seconds

3. Reconnect Battery

4. Start car. DO NOT TOUCH THE GAS. Idle for AT LEAST 15 minutes. DO NOT TOUCH THE GAS. (I keep repeating this for a reason).

5. Go drive the car.

ALSO, VERY IMPORTANT to note that the intake air temperature is measured at the MAF. You DO NOT want the MAF sitting right off the torquebox right above the warm engine. You want it as far away from the engine as possible. Otherwise, your IAT's will be higher than they normally would, which will hurt performance (retarded timing for warmer IAT's).

In other words, your intake is shit. Do it right or go back to stock.
 

·
Registered
Joined
·
4,360 Posts
Have you tried an ECU reset yet? In my experience with the DBW cars, sudden weird behavior with no other indicators like a CEL, can be cleared up with an ECU reset. If it's still there after the reset, time for a dealer visit.
 

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #14
ill try an ecu reset tomorrow. the reason why i chose a short ram is because i drive in crap weather all the time, and i love the sound/minor power gain of an intake.

i dont want to go back to stock, i want to get an intake that works at least.
 

·
Registered
Joined
·
4,360 Posts
maxipad said:
i dont want to go back to stock, i want to get an intake that works at least.
HAHAHAHAHAHAHAHAHA, you realize that ALL intakes do this right? Your only option is "back to stock". A little research would have saved you some money.
 

·
Registered
'05 RS2.5 crystal grey
Joined
·
137 Posts
Discussion Starter #17
w/e, i spent less than $100 so im not too worried about it. it sounds good, helps me pass on the highway, and doesnt bog too often. ill let it sit for now and just do an ecu reset tonight and see how it goes.
 
1 - 17 of 17 Posts
Top