Subaru Impreza GC8 & RS Forum & Community banner
1 - 13 of 13 Posts

·
Registered
2000 WRX/STi Coupe
Joined
·
437 Posts
Discussion Starter · #1 ·
So I'm looking for help on diagnosing a problem I discovered just as I came home from a track day.

Coming from the front right, I started getting a knocking sound. It would start doing it at certain speeds, stop sometimes, then continue randomly. I pulled over and nothing was hitting, everything looked normal. I was almost home so I parked it and decided to check it out this morning.

So I inspected both CV joints, the brakes, and anything that would be making contact. Nothing, so I disassembled the brakes and got it just down to the hub (with axle attached).

When turning the hub by hand, it would reach a certain point then "click" a few milimeters over. It would just sort of give out at a point then stop again normally. When rotating the wheel in the air, it would make a noise that sounded like what I was hearing last night.

So I decided maybe the axle wasn't seated well in the hub and put my impact on the axle nut and got a quarter turn out of it, knocking some debris and rust free at the same time.

Turned the hub again and the noise was gone..seemed to be moving smoothly. Put everything back together and put 10 miles on it, and it seems to be back to normal. However I'm concerned its going to come back. Anyone have any idea what it could be?

Wheel bearing tests fine, there's no play in it.
 

·
Registered
2000 WRX/STi Coupe
Joined
·
437 Posts
Discussion Starter · #3 ·
Yeah, the boot was all scrunched up and weird on that side, so I decided to replace it. This was 4 months ago or so.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
lower ball joint?
 

·
Registered
2000 WRX/STi Coupe
Joined
·
437 Posts
Discussion Starter · #5 ·
I don't know why the ball joint would be rotational. I think I'm going to replace those anyway, but I don't think thats causing this problem.
 

·
needs more cowbell
95L, 07 2.5i, R6
Joined
·
9,316 Posts
Well although I like advance for their new parts I did have to go through a few front cv shafts (boots exploding, clicking, etc) before I ended up with a set that are working well.
 

·
Registered
2000 WRX/STi Coupe
Joined
·
437 Posts
Discussion Starter · #9 ·
Yeah, I bought a remanned axle for my old Legacy Turbo from a guy who rebuilds OEMs. I might go that route, since I have my old one still as a core and he's usually cheap and very good.

I can't seem to remember his website...anyone know what I'm talking about, or recommend where to get an axle good and cheap?

Edit: Found it, cvaxles.com
 

·
Registered
Joined
·
290 Posts
I blame the third party axle for the noise. Since you fixed it by tightening the axle nut, I guess everything is all good.
 

·
Registered
2000 WRX/STi Coupe
Joined
·
437 Posts
Discussion Starter · #11 ·
Yeah I'm just not sure how long its going to last. I think I'm going to send my mostly-good stock axle to cvaxles.com to get it refreshed.
 
1 - 13 of 13 Posts
Top